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PREFACE 

 

Today’s society is shaped by sudden growth and development of the information 

technology (IT) resulting with its great dependency on the knowledge and 

competence of individuals from the IT area. Although this dependency is growing 

day by day, the human right to education and information is not extended to the 

IT area. Problems that are affecting society as a whole are emerging, creating gaps 

and distancing people from the main reason and motivation for advancement-

opportunity. Being a computer illiterate person today means being a person who 

is unable to participate in modern society, and a person without opportunity; and 

despite the acknowledged necessity and benefits of inclusive computer literacy 

from institutions like the European Commission, UNESCO, OECD, there are still 

groups of people having difficulties accessing basic computer education viz. 

persons with disabilities, persons with learning difficulties, migrant workers, 

unemployed persons, persons that live in remote (rural) areas where IT education 

is not accessible.  

This handbook, combined with other materials published on ITdesk.info, 

represent our effort and contribution to the realization and promotion of human 

rights to education and information considering the IT area. We hope that this 

education will help you in mastering basic computer skills and with that hope we 

wish you to learn as much as you can, and therefore become an active member of 

modern ICT society. 

 

Sincerely yours,  

ITdesk.info team Expert review of Croatian version: 
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DATABASE - BASIC CONCEPTS 

A database is a structured collection of interrelated data. In a relational database, data is 
stored in tables. 

The difference between the terms “data” and “information”:  

A piece of data is a fact that can be represented as audio, video, text or number(s). By itself, 
it may not be relevant, but if it is processed and put in a certain context, it takes on a 
meaning and becomes information. Information is the context- the meaning attached to the 
data. 
For example, the sound of an alarm is data. If you listened to it out of context, it would be 
just an unpleasant and penetrating sound. After it was assigned the meaning "imminent 
danger", it became (well known) information. 

Examples of large database use: 

 plane ticket reservations 

 government institutional databases 

 bank accounts 

 patient data 

1.1 Database organization 

A table is the most important database element. It is composed of rows and columns that 
contain information on a certain subject. For example, the table "Customers" contains the 
necessary information about customers. 

A Record in a table is displayed as a row and contains information about a subject, e.g. 
relevant information about a customer. 

Fields are individual record characteristics which are displayed as columns within a table. 
The type of data that can be entered in a field is specified as the data type (textual, logical, 
currency, numeric etc.), e.g. name, address, city, telephone, e-mail etc. 

Cells are the rectangular spaces where the rows and columns intersect, and where the date 
is entered. 

Besides the type, within the fields we can also determine: 

 Field size 

 Format – e.g. we can specify what currency indicator is added to the amount 

 Default Value – if nothing is entered, the value that we enter here will be written in 
the field 

 Validation Rule – checks whether the entered information is correct, i.e. checks 
whether the set criteria is met                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Noncommercial-No Derivative Works 3.0 Croatia License            4/41 

 

Fig. 1. Table records and fields    

Why should each table field contain only one data element, one type of information? 

In Figure 1, Table records and fields, you can see an example of good table design, i.e. each 
field contains only one data element. Name is entered in one field, last name in another, 
street and number (address) in the third etc. A bad design example would be this:  

 

Fig. 2. Bad design example   

In the previous example, there are two data elements in one field (first and last name in the 

Name field) and three data elements in another (street number, city and zip code). The data 

is inflexible, making it very difficult to sort and create queries and reports. 

Better design example in comparison to the previous table would be this: 

 

Fig. 3. Better design example 

With every data element in a separate field, it is easier to sort and create queries and 
reports. 

 

Connection between data types and field content  

Field content is a particular data type within a table. It can be text, number, currency, date 
and time, yes / no, etc. 

 

Field 

Record 
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Fig. 4. Data types 

To add a field, click on the table header labeled Click to 
Add. Another way to add a field is via the Design View, in 
the Data Type column.  

  

Fig. 5. Data Type 

 

 

Basic field properties  

Table fields have the appropriate properties, such as field size, formatting and default 
values. These properties can be changed in the Field Properties in Design View.  

  Fig. 6. Field Size property 

Field Size – for example, pre-set to 255 
text characters. 

 Fig. 7. Field properties display 

 

Format – for example, there are several formats for date and time (General, Long, Short, 
etc.). 

  

Fig. 8. Field properties display 

Default Value – for example, for Yes/No data type, default value is 0. 
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1.1.1 PRIMARY KEY 

A Primary Key is a field, which clearly identifies each 
table record. A very important part of designing a 
database is to determine the primary key for each 
table. You should take into account that it is unique 
for each record. Figure 9 shows the primary key as an 
ID field which is assigned as the AutoNumber data 
type, which means that by entering each new record, 
the system itself generates a new unique ID (number). 

Indexes are automatically assigned to primary keys, 
which significantly accelerates the search and data 
retrieval. Primary keys are often used to create 
relationships between tables. 

 

Fig. 9. ID field set as primary key  

 

1.1.2 INDEXES  

Data locations are stored in indexes. Table indexes are used as term indexes in books - when 
searching for information, its location is looked up via an index. We use them to speed up 
the search and data retrieval. For tables with a small number of records, using indexes is not 
required, because speed improvement when searching or sorting is negligible. However, if 
we have a lot of data, by setting the appropriate indexes on certain fields, we can expect a 
significant search and sort acceleration. 

 

1.2 Connecting tables -  relationships  

Often, a database consists of several tables. For example, an internet shop database could 
include, among other tables, Customers and Shipping tables. The mere fact that we can have 
multiple tables within a database suggests that the tables can be linked. The link between 
tables within a database is called a Relationship. 

Relationships (connections) between tables are made through primary key fields and on the 
principle of field equality. We connect tables to be able to make queries, reports and forms 
with data located in multiple tables. In Figure 10 we have connected a Customer ID field 
which is the primary key of the Customers table with the Customer ID field from the 
Shipping table.  
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To create a relationship between two or more tables, we need to have fields that have the 
same data type in the relevant tables (* fields need not have the same name!). In Figure 10 
there are Customer ID fields, which are 
identical in the Customers table and in the 
Shipping table. 

 

Fig. 10. Relationship (1xn) between  
Customers and Shipping tables  

 

Relationship types: 

1:M (One to Many) – one field in the relationship is the primary key of its table. This is the 
most common relationship type. 

1:1 (One to One) – both fields in the relationship are primary keys of their tables. This is the 
most uncommon relationship type. 

M:M (Many to Many) – in this relationship, a third table is created in which the primary key 
consists of two fields that are foreign keys from the linked tables. 

 

Create a relationship between tables 

In order to create a relationship between tables, on the Database Tools tab, within the 

Relationships group, choose the Relationships tool  . 

To display the tables you want to connect, choose the Show Table tool  on the Design 
tab in the Tools group. 

The Show Table dialog box opens (Fig. 11.) in which 
you first select and then press the Add button to add 
the tables to be displayed within the Relationships 
pane.  

 

 

Fig. 11. Show Table dialog box  
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A relationship can also be created via the drag and drop method (Fig. 12.) by following these 
steps: 

1. Position the cursor over the first table primary key (ID field to Customers table) 
2. Press and hold the left mouse button, pull the cursor over to the Customer ID field in 

the Shopping cart table and release the mouse button  
3. Edit Relationships dialog box opens (Fig. 13.) 
4. Press the Create button to create a relationship  

Fig. 12. Create relationship between Customers and 
Shopping cart tables via drag and drop method 
       Fig. 13. Edit Relationships dialog box 
 

Why is it important to preserve the referential integrity between tables? 

The referential integrity ensures the integrity of all database records. By its application, 
validity of the relationship between the tables is confirmed and accidental modification or 
deletion of the related data is prevented. 

In the Edit Relationships dialog box (Fig. 13), check the Enforce Referential Integrity option. 
After that, if you try to delete a record from the Customers table (which is connected to the 
Shopping cart table), a Microsoft Access application warns that the record cannot be 
deleted, because the other table includes the related records (Fig.  14). 

  Fig.14. Warning about related records  

Delete a relationship between tables 

First, select the relationship, and then: 

 press the right mouse button and from the pop-up menu choose the Delete 
command, or 

 press the Delete key on the keyboard 
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Who creates, manages, fills out and maintains a database? 

Database designers are experts who create professional databases. 

Database administrators are responsible for database maintenance and functionality. 
Among their tasks is the determination of data access permissions for a particular category 
of users. Database administrators ensure database recovery in case of failure or major 
errors. 

 

A Database user handles data entry, data maintenance and information retrieval. 

A Database administrator has the highest level of database user rights (access and 
manipulation). He/she grants or withholds data access rights. The database administrator is 
responsible for functioning, backup and database recovery in case of failure. 
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2 DATABASE APPLICATION - MICROSOFT ACCESS 2010 

2.1 ELEMENTS OF APPLICATION WINDOW 

Buttons to manipulate the window, located on the right-hand side of the title bar; are used 
to maximize, minimize or close the window. 

The Title bar contains information about a database and an application in which it is open. 

Tabs: 

 File - used to perform basic operations on the database (save or open an existing 
one, create a new one etc.) 

 Home – contains tools for word processing, sorting, commands for copying, cutting 
and pasting 

 Create – used to create database objects (tables, queries, forms and reports) 

 External Data – contains tools used to manage data import 

 Database Tools – contains tools used to compress and repair a database (Compact 
and Repair Database), to display relationships and object dependencies, Visual Basic 
Editor etc. 

Extra contextual tabs appear when a database object is open. In Figure 15, notice the new 
tab Table Tools, with Fields and Table tabs that appeared after we opened a table. 

  

Fig. 15. Additional Table Tools tab 

 

Quick Access Toolbar is there for an easy access to the most often used tools. It can be 
displayed above or below the Ribbon. 

  Fig. 16. Quick Access Toolbar 

 

The Ribbon contains tabs with logically grouped commands. 

 

Fig. 17. Ribbon 
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The Navigation Pane is located on the left side of the window and it 
lists all database objects: 

 Tables 

 Queries 

 Forms 

 Reports 

Fig. 18. Database objects pane  

 

Bars for horizontal and vertical navigation (sliders) are used to navigate to the desired 
location. 

Above the status bar, there is a record navigation bar. 

 Fig. 19. Record navigation bar 

Status bar displays information about the possible view of the object. 

 

2.2 BASIC TASKS: OPEN/CLOSE DATABASE OR APPLICATION 

To run an application: 

 On the Start menu – click All Programs and from the Microsoft Office folder choose 
Microsoft Access 2010 

 Using the Search function, enter the word “access” into the search box and from the 
search results list choose Microsoft Access 2010 

 Double-click the program shortcut (usually found on the computer desktop) 

 

To close an application: 

 Click the Close button, located on the window’s Title bar  

 Click on the File tab and choose the Exit command 

 Use the keyboard shortcut: Alt + F4 

 

2.2.1 OPEN/CLOSE A DATABASE 

To open an existing database: 

 Click on the File tab and choose the Open command 

 Use the keyboard shortcut Ctrl + O 
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 Double-click the left mouse button on the database icon 

 Press the right mouse button on the database icon and choose the Open command 

To close a database: 

In order to close a database, choose the Close command from the File menu. 

2.2.2 CREATE A NEW DATABASE AND SAVE IT TO THE LOCAL COMPUTER  

To create a new database:  

From the File menu, select the New command. If you want to create a new blank database, 
select the Blank Database template and confirm your selection by pressing the Create 
button. 

To save a database 

Save your database by clicking on the Save command on the File menu. To save, you can also 

use the keyboard shortcut Ctrl + S or the Save button , located on the Quick Access 
Toolbar. 

Before saving the database, it is necessary to close (and save) all database objects. If this is 
not done, a dialog box will appear with a warning (Fig. 20). 

 

Fig. 20. Closing all open database objects before 
saving the database 

If objects are not saved, you can do it now.  

  Fig. 21. Save table   

In case that the table is being saved for the first time, the Save As dialog box appears in 
which you can enter the table name. 

Fig. 22. Save As dialog box –  
first time saving table  

After closing and saving all objects, the database can 
be saved. 

2.2.3 SETTING THE WORK ENVIRONMENT - RIBBONS AND TOOLBARS 

In order to set the Ribbon, open File menu, click on the Options button and open the 

Customize Ribbon tab. If you dont want any of the default tabs to show, simply remove the 
checkmark next to it. There is also a possibility to create your own tab that can be adjusted 
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to fully meet your needs. On the dialog box on the left side, select the desired tool and click 
the Add button to add it to the tab. If you want to remove a tool from the tab, select it and 
click the Remove button. 

Minimize the Ribbon: 

 On the Ribbon, press the right mouse button and from the pop-up menu, select the 
Minimize the Ribbon command 

 Click on the arrow  located on the upper-right corner of the ribbon 

 Double-click on the tab's name 

Maximize the Ribbon: 

 On the Ribbon, press the right mouse button and from the pop-up menu, select 
Minimize the Ribbon (remove checkmark) 

 Click on the arrow  located on the upper-right corner of the ribbon 

 Double-click the tab's 

name 

 

 

 

 

 

Fig. 23. Setting the Ribbon 

 

 

Setting the Quick Access Toolbar: 

The Quick Access Toolbar is used for a quick access to the most often used tools. On the File 
menu click on Options and select the Quick Access Toolbar tab. Depending on needs, add 
the desired tools and remove the unnecessary ones. 
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The Quick Access Toolbar can be displayed above or below the Ribbon. Press the right 
mouse button over the Ribbon, and choose the Show Quick Access Toolbar Below the 
Ribbon or Show Quick Access Toolbar Above the Ribbon command from the pop-up menu. 

 

 

 

 

 

 

 

 

Fig. 24. Setting Quick 
Access Toolbar 

 

Help function 

The Help function can be accessed via the File menu. On the right side of the window, there 
is information on the used application version. Selecting the Microsoft Office Help tab, a 
window opens with a list of available help topics. In the Search text box, write the term you 
want to explore. The Help function can also be opened by clicking on the icon 
located below the manipulation buttons, or by pressing the F1 key on the keyboard. 

 

2.3 WORKING WITH DATABASES 

Open a table: 

 Double-click the table within the Navigation Pane 

 Position the cursor over it, press the right mouse 
button, and choose the Open command from the quick 
menu 

 

Fig. 25. Object pane that has listed one table  
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Save a table, query, form or report 

In order to save an object, choose the Save command from the File 
menu. 

Fig. 26. File menu – Save command 

 

Close a table, query, form or report 

An object is closed by pressing the Close button. You can also use the keyboard shortcuts 
Ctrl+W and Ctrl+F4. 

 

Types of views for a table, query, form or report 

The view of the table is changed via the View tool. To display the table at Design View, click 

the View icon  on the Home tab. 

 

Delete a table, query, form or report 

Within the navigation pane, select the object (table, query, form, report) that you want to 
delete and: 

 Right-click and choose the Delete command from the pop-up menu 

 On the Home tab under the Records group, choose the Delete command 

 

Navigate through records and fields in a table, query or form by: 

 pressing buttons on the record navigation bar   

 pressing the following keys: up, down, left, right, PageUp, PageDown, Tab, Home, 
End 

 left-clicking over the field, or on the gray border at the left side of the record 

Sorting records in a table, query or form in an ascending or descending order, numerically 

and alphabetically 

 On the Home tab within the Sort & Filter group, choose a tool to sort in an ascending 

 or descending order  
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If you selected a field in which the set data type is a default numeric value (AutoNumber, 
Number, Currency), click the right mouse button over it and choose Sort Smallest to Largest 
or Sort Largest to Smallest from the pop-up menu. 

 If you selected a field in which the data type is set as text, 
press the right mouse button and choose Sort A to Z or Sort Z 
to A from the pop-up menu. 

 

 

 
 

Fig. 27. Quick menu – commands to sort  
numeric values 
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3 TABLES 

3.1 RECORDS 

Add records to a table 

To add records, click on the record marked with an asterisk and enter your data. In the 
example presented in Figure 28, the content cannot be entered in the Author ID field, 
because it was assigned as the AutoNumber data type i.e. the system will automatically 
generate the number. 

Fig. 28. Adding a new record 

Delete a record from a table 

In order to delete a record, first select it and then press the Delete key. 

Change data in a record 

Select information or the part of the data that you want to modify, delete the entry with the 
Delete key and enter new data. You can select the entire record and write new data. 

Delete data within a record 

Select information or a part of it and press Delete in order to delete it. 

 

3.2 DATABASE DESIGN 

Create and name the table 

A table is created via the Create tab, by choosing the Table tool  within the Tables 
group. 

By pressing the Close button, a dialog box appears asking whether you want to save the 
table. If you reply “yes”, the Save As dialog box appears in 
which you can enter the table name. 

Fig. 29. Save As dialog box 
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Design View - after you determine the field name, click 
to the right of it on the Data Type column, and from 
the drop-down menu, select the appropriate data type. 

 

Fig. 30. Design View -  
set Data Type  

 

Often used data types: 

 Text - accepts text and numeric characters 

 Number - accepts only numeric characters 

 Date/Time - date and time entry 

 Currency - currency values entry 

 AutoNumber - the system automatically generates an ordinal number for each 
record, entry is not permitted  

 Yes/No 

Datasheet View –on the Fields tab under the Table Tools tab, within the Formatting group, 
click on the Data Type drop-down menu to set the data type. 

 

Fig.31. Datasheet View - determining the field type 

3.2.1 WORKING WITH FIELD SETTINGS 

Modify field settings (via Design View) 

Field Size - if a text is assigned as the field data type, here you set the field size (maximum 
size is 255 characters). 

Fig. 32. Setting the field size 
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Format – if a number is assigned as the field data type, choose from a number of formatting 
options (general, currency, percent etc.) from the drop-down menu next to the Format label. 

 

Fig. 33. Choose number format 

Date/time – if date and time are assigned as the field data type, select among a number of 
formatting options from the drop-down menu next to the Format label. 

 

Fig. 34. Choose date/time format 

Default Value – via this property, we determine the value that Microsoft Access 
automatically enters in a table if nothing is entered within a selected field (e.g. Figure 35, if 
nothing is entered within a selected field, 0 will be entered). 

 

Fig. 35. Default Value 
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3.2.2 VALIDATION RULE 

The Validation Rule is used to verify field input values. If you type in the expression “<50”, 
all numbers greater than or equal to 50 cannot be entered into this field and the application 
will give you a warning. 

If you write validation rules for a field formatted as date, before and after each date you 
must put the # sign. For example, to ensure that data referring to dates between 
01/01/1970 and 01/01/1975 cannot be entered, set the following rule: >#01/01/1970# and 
<#01/01/1975#. 

Fig. 36. Setting Validation Rule in Design View 

The hazards of changing data types and table field settings 

For example, if you try to type a text in a field with data type set as number, the system will 
give the user an error notification, because only numeric values can be entered in the 
Number field. Changing data type and attributes should be handled carefully, because it may 
lead to data loss and affect data consistency. 

3.2.3 PRIMARY KEY 

The primary key is a field that uniquely identifies each 
record stored in a table. 

 

 

 

 

 

Fig. 37. ID field is primary key; data type: AutoNumber 
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Defining a field as a primary key (via Design View) 

Before defining the primary key, it is necessary to switch to Design View, select the field that 
will be defined as the primary key and: 

 in the Tools group (under the Table Tools tab on the Tables tab), choose the Primary 

key icon  , or 

 right-click over the selected field and choose the Primary key command from the 
pop-up menu 

 

Remove a primary key 

 in the Tools group (under the Table Tools tab on the Tables tab), choose the icon 

 , or 

 right-click over the selected field and choose the Primary key command from the 
pop-up menu 

 

3.2.4 FIELD INDEX  

Indexes are automatically assigned to primary keys and double records are not allowed. The 
fields’ index property (Indexed) is defined in the General tab: 

 No - the default option for all fields except the primary key to which the index is 
automatically assigned without duplicate entries 

 Yes (Duplicates OK) - set the field index and allow duplicate records 

 Yes (No Duplicates) - indexes the field and does not allow duplicate values 

 

Fig. 38. General tab - Indexed property  
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3.2.5 ADD FIELDS TO A TABLE 

 Via Datasheet View - select a column before which you want to add a field and press 
the right mouse button. Choose the Insert Field command from the pop-up menu. 

 Via Design View - under the Table Tools tab on the Design tab, select the Insert 

Rows button  , or select a field, press the right mouse button and choose 
the Insert Rows command from the pop-up menu. 

 

3.2.6 MODIFY COLUMN WIDTH IN A TABLE 

On the Home tab, within the Records group, choose the More 
command, then on the drop-down menu click on Field Width and enter the desired value. 
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4 INFORMATION DISPLAY 

4.1 BASIC FUNCTIONS 

4.1.1 FIND AND REPLACE FUNCTIONS 

The Find and Replace functions are used when we want to find and replace a small amount 
of data. These functions are located on the Home tab, within the Find group. They can also 
be accessed via keyboard shortcuts: Ctrl+F - for the Find function and Ctrl+H for the Replace 
function. 

Search records 

When searching for some information within a table, first select the field you are searching 
in, and then in the Home tab, choose the Find icon. 

In the Find What text box write the data to search for and click the Find next button. 

 

  

 

Fig. 39. Find and Replace dialog box 
– Find function 

 

The Replace function 

In order to replace some data, after you have selected a field, click on the Replace icon 

 on the Home tab. 

In the Find What text box enter the data to search for, and in the Replace With text box 
enter the data you want to replace it with. Then click on the Find Next button and when 
Microsoft Access finds it, click on the Replace button. 

 

 

Fig. 40. Find and Replace dialog box – 
Replace function 
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4.1.2 WORKING WITH FILTERS 

A Filter is used to restrict data display to only certain records, while setting certain 
conditions. Data that do not meet this condition will not be displayed. 

The Tool for filtering data  is on the Home tab within the Sort & Filter group. 
Select  the field that you want to filter e.g. Last Name, and choose the Filter function. In the 
open dialog box via the Text Filters command (data type in the field is text), choose the 

condition Equals and in the Custom Filter dialog box 
that opens up, enter the last name you want to filter 
(e.g. Cohen). The table will show the records for all 
the people with the surname Cohen.  

. 

                                 

 

Fig. 41. Filtering data in the “Last Name” field   Fig. 42. Custom Filter dialog box 

 

Remove a filter 

Remove a filter by clicking on the Filter icon displayed on the filtered field header (Fig. 43.) 
and then by choosing Clear filter from fieldname command. 

  Fig. 43. Remove filter 
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4.2 QUERIES 

What are queries? 

Queries in Microsoft Access are used to extract data from tables that have met a certain 
condition. They can serve to change the data, and for data analysis. Also, query results can 
be data sources for forms and reports. 

4.2.1 CREATE AND NAME A QUERY FROM ONE TABLE  

Using specific search criteria  

Queries can be created with the help of Query Wizard or by using Query Design. With Query 
Design we determine the data with which we want to work with, tables or queries from 
which this data is, and we define the criteria. 

Query Wizard and Query Design are located on the Create tab within the Queries group. 

 

Fig. 44. Create tab 

As an example, we will show how to create a query from the following table: 

 Fig. 45. “Furniture" table

   

To run a simple query from a table, run Query Design and choose which data source (e.g. 
“Furniture” table) to use. Previously saved queries can also be used.  
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  Fig. 46. Show Table dialog box  

After that, choose the fields that you want to display in a query. The easiest way to do so is 
to use the drag and drop method, or to use the menu that appears when clicking in one 
field. In this case, we add Description, Type and Price fields to the query. 

  Fig. 47. Add fields 

Now you can add certain criteria, provided that the text criteria are in quotation marks. For 
this example, we have set that our query prints all the furniture that is "Chair". 

 Fig. 48. Enter criteria 
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And this is the query result: 

 Fig. 49. Query result 

Creating queries by using a specific search condition 

To run a query from two (or more) tables, using specific condition(s), we follow all the steps 
presented in the above example, just using more tables. In addition, the tables that you use 
must be connected (there must be a relationship) with one another.  

For example, we have the Customers table (which has the following fields: ID, Name, Last 
Name, City, Tel, Address) and the Customers interests table (which has Product ID, 
Customer ID and Product). The tables are linked via the Customer ID field. We will create a 
query with just Name, Last Name and Product fields. 

First we add the Customers table and the Customers interests table. Then, by using the drag 
and drop method (or menu), add fields to be displayed in the query (Name and Last Name 
from the Customers table, and the Product field from the Customers interests table) and run 
the query. 

 

4.2.2 Add conditions  to a query  

Adding operators to a query 

We can add operators to criteria, by using one or more of the following operators: = 
(equals), <> (different from), < (less than), <= (less than or equal to), > (greater than), >= 
(greater than or equal to). 

For example, from the Furniture table, we can run a query that will return only records that 
contain prices greater than €3.000 for which purpose we use the “>” operator. 

 

Fig. 50. Adding criteria “greater than 3.000” to Price field 
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Query result is as follows: 

 Fig. 51. Query result 

 

Adding logical operator(s) to a query 

Logical operators are: AND, OR and NOT, and we can use one or more logical operators in a 
query. 

For example, NOT “Chair” criteria on the Type field will return all table items except chairs as 
query results. “Chair” OR “Clock” will return all chairs and clocks as query results.  

 

4.2.3 JOKER SYMBOLS AND HOW THEY ARE USED IN A QUERY 

Wild characters (* or % or ? or _) are commonly used in conjunction with the Find & Replace 
dialog box to find and replace data in a Microsoft Access database and can be used in 
queries. 

 * coincides with any number of characters. Use an asterisk anywhere in a word, e.g. 

tele* will find telephone, television and telecommunications. 

 ? coincides with any alphabetic character, e.g. p?n will find words pin and pen. 

 [ ] coincides with any character in parentheses, e.g. c[ei]la will find words like cesta and 

cista. 

 ! coincides with any character not in parentheses, e.g. b[!ae]la will find words bila and 

bola, but not bala or bela. 

 - coincides with any character in the range. The range can be specified in an ascending 

order, e.g. r[t-v]pa will find words rtpa, rupa and rvpa. 

 # coincides with any numeric character, e.g. 19#3 finds 1903, 1913, 1923… 1983 and 

1993. 
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4.2.4 FORMAT QUERY 

Add, modify or delete criteria 

To modify or delete criteria you need only select it and then change it by typing, or delete it 
by using the Delete key. 

To add more conditions, you can use the OR logical operator or other field criteria, as shown 
in the figure below. 

 Fig. 52 Add criteria 

By setting these conditions, the query will return all chairs, clocks and cabinets. 

 

Fig. 53 Add criteria by 
entering operators 

The query displays all the customers from Zagreb and Split whose last name is not Marušić.  

We can add, delete, move and hide/unhide fields via Design View. We have already 
explained adding, while to delete a field only select it i.e. position the mouse cursor on the 
header and, when a black arrow appears, press the left mouse button and press the Delete 
key. 

To move a field, select it and press the left mouse button. When a small square appears, you 
can move the field where you want to by using the drag and drop method. 

To hide/unhide a field from the query results, mark (or clear) the Show check box. 

 Fig. 53. Show check box 

4.2.5 RUN A QUERY 

Run a query by choosing the Run command  located in the Results group on the Design 
tab, under the Query Tools tab. 

Query results are displayed in the data table called dynaset (Dynamic Set) - the data is 
selected and sorted according to a query (criteria), from one or more tables. It is not a fixed 
table, but a dynamic "view" of information that we can change and enter new ones.  
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5 OBJECTS 

Database objects 

A Table is the most important element of any database. It is used for data storage. It consists 
of records that are presented in rows, and fields that are presented as table columns. 

Queries provide an overview of one or more tables, enable sorting and selection of data, 
addition and deletion of data etc. 

Forms are used to enter, delete or modify data in tables with data seen in graphical 
representation and not in tables. 

A Report is used when preparing data for printing. It is the database output. 

Macros are used to automate actions or procedures. They define actions that are executed 
in response to specific events (e.g. we run the query by pressing a button to which we have 
assigned the macro).  

Modules are blocks of code written in the VBA programming language (Visual Basic for 
Applications).  

5.1 FORMS 

A Form is a database object whose role is to interact with the user. The user does not see 
the table, but the forms that show the records, which are in this way more easily viewed and 
edited. 

Creating and naming a form 

Create a form by first selecting the table, then click the Form button located in the Forms 
group on the Create tab, and the Microsoft Access application will automatically create a 
form with all the fields from the table. 

Fig.  54. Form automatically created by pressing Form button located on Create tab 

A Form can also be created via Form Design or Form Wizard. If you opt for Form Design, add 
all the fields manually and format them as desired. 
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Fig. 55. Form Wizard – Design View 

 

5.1.1 USING FORMS  

Using forms to add new records 

The advantage of using forms is the ability to enter new records without using tables. Click 

on the New Blank Record button on the record navigation bar which will insert a new 

record. 

 Fig. 56. New Blank Record button 

 

Fig. 57. New record entered via form 
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Using forms to delete records  

By using the navigation buttons on the record navigation bar, select the record you want to 

delete (while in Form View), and click on the Delete button  located on the Home 

tab within the Records group. 

Using forms to add, edit or delete data 

Via forms, you can modify and delete old data, and add new ones. Just go to the relevant 
record and enter new data, or delete the existing data using the Delete key. 

In the Furniture example form, the ID field is generated automatically; enter the data for the 
Description and Price fields manually, and choose Type from the drop-down menu. 

 

Fig. 58. Modify/delete records via forms 

5.1.2 EDIT HEADER AND FOOTER  

Add and modify a text in header and footer easily via form in Design View. Modification can 
also be done in the Layout View. 

It is necessary to first select the text in header or footer and enter new text. 

 

Fig. 59. Enter text into header 
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6 REPORTS 

Simply put, a report prints a list of table records or a query. For this purpose you could use 
the Print command, but if you want to achieve a more professional look, use reports. 

 

6.1 REPORTS AND DATA EXPORT 

6.1.1 CREATE AND NAME A REPORT BASED ON A TABLE OR A QUERY  

As with forms, first select a table or a query. Then click on the Report button in the Reports 
group on the Create tab, and the Microsoft Access application will automatically generate a 
report. You can also use the Report Wizard, or design the report yourself via Report Design. 

 

Fig. 60. Navigation pane and display of selected table as report 

The Furniture table was selected and we have 
created a report (Fig. 60) by using the Report 
button. 

In the Report Design we manually design the report, 

add fields, and place them where we want. 

  

Fig. 61. Report Design 
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The Report Wizard leads us through the following steps to define all required elements: 

   

   

 Fig. 62 Report Wizard 

 

6.1.2 ADJUST DATA FIELDS POSITION  AND TITLES IN A REPORT 

To modify data fields position and titles within a report, go to Design View, select the field, 

and when the cursor changes to a shape of 4 arrows (directions: up, down, left, right), move 

the field to a new location via the drag and drop method. 
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Fig. 63. 

Design 

View 

 

6.1.3 REVIEW OF CERTAIN FIELDS IN A REPORT GROUPED ACCORDING TO CRITERIA 

In reports, there can be fields for minimum value, maximum value, average, count, and so 
on. 

Select the field in which you want to get the sum (or other value), click the Totals button and 
select the function you want. The field appears with the sum (or other) in Report Footer, 

which you can place at will. 

 

 

 

 

Fig. 64. Totals drop-down menu with   Fig. 65. Sum field in report via Design View 
available functions  

6.1.4 EDIT HEADER AND FOOTER 

As with forms, the easiest way to add and edit the text in header and footer in report is in 
the Design View. Again, just select the text in header or footer, delete it or enter a new one. 

6.1.5 EXPORT A TABLE OR A QUERY RESULT  

Export a table to a spreadsheet (.xslx) 

To export a table or a query result to a spreadsheet, use the Excel tool  located in the 
Export group on the External Data tab. Press the Browse button to select the name and 
location to save the worksheet. There are several export options: 

 Export data with formatting and layout – preserves formatting and table data layout 

 Open the destination file after the export operation is complete – opens the 
worksheet with exported data (available if you selected the previous option as well) 

 Export only the selected records – exports only the selected records (available if you 
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had selected the option to export formatted data and have records selected as well) 

 

 

 

 

 

 

Fig. 68. Export dialog box - 
destination format: Excel 
Spreadsheet 

 

Export data to a text file (.txt) 

Use the Text File tool  located in the Export group, on the External Data tab. Press the 
Browse button to select the name and location to save the file. 

Export data to an XML data file (.xml) 

Use the XML File tool  located in the Export group, on the External Data tab. Press the 
Browse button to select the name and location to save the file. In the Export XML dialog box 
that opens up (Fig. 68.), mark the Data (XML) option. 

  Fig. 69. Export XML dialog box 
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6.2 PRINT 

Set printing layout 

From the File menu choose the Print command, and then choose the Print Preview tool. In 
the Page Layout group, by using the Portrait and Landscape icons, change the page 
orientation. By using the Size icon within the Page Size group, change the paper size. 

 

Fig. 70. Print preview 

Use the Print command 

 Click on the File tab, and select the Print command  

 Use the keyboard shortcut Ctrl + P 

 Click on the Print icon located in the Print Preview tab 

 

 Fig. 71. File menu 
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6.2.1 PRINT SETTINGS  

Print range: 

 All – use this option to print the entire table, report or query 

 Pages From – prints a certain page range 

 Selected Records – prints only the selected records of a table, query etc. 

Number of copies: 

If you want to print a database object e.g. a table, in several copies, enter the number of 
copies in the Number of Copies field.  

 

  

 

 

Fig. 72. Print dialog box 

 

 

6.2.2 PRINT A RECORD BY USING A FORM 

For example, if you want to print records from 4 to 8, first position the cursor on the record 

4, click on Record Selector , press the Shift key and use the navigation buttons to 
navigate to the record 8. Release the Shift key and on the File menu select the Print 
command. 

 

6.2.3 PRINT A QUERY 

After you opened a query by double-clicking it, select the Print command from the File 

menu, and if you do not need to adjust the settings, click the Quick Print button .  

The Quick Print button can be added to the Quick Access Toolbar, making it easier to use. 
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* Add a button on the Quick Access Toolbar by clicking on the arrow on the right of the 
toolbar, and select the tools that will appear on the Quick Access Toolbar from the drop-
down menu. Similarly, in order to remove the 
tools from the Quick Access Toolbar, just click 
on them so that they are unchecked. 

  

 

 

 

Fig. 73. Customize Quick Access Toolbar 

 

 

6.2.4 PRINT A REPORT 

In the navigation pane, select the report that you want to print, press the right mouse 
button over it, and choose the Print command from the quick menu. 

  Fig. 74. Navigation pane 
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This handbook is intended for learning in conjunction with materials 

published on the following links: 

 

 

* Sample exam for module 5 is published at: 

http://www.itdesk.info/sample exam/sample exam module 5.pdf 

  

* Solution for this sample exam is published at:  

http://www.itdesk.info/en/exam-solution-module-5/ 

 

* Video presentations showing the work in the Microsoft Access 2010 application are available at 

the following links: 

 http://www.itdesk.info/en/microsoft-access-2010-using-databases-1/ 

 http://www.itdesk.info/en/microsoft-access-2010-using-databases-2/ 

 

* Quiz for self-evaluation is published at:  

http://www.itdesk.info/en/databases-quiz/  

  

http://www.itdesk.info/sample%20exam/sample%20exam%20module%205.pdf
http://www.itdesk.info/en/exam-solution-module-5/
http://www.itdesk.info/en/microsoft-access-2010-using-databases-1/
http://www.itdesk.info/en/microsoft-access-2010-using-databases-2/
http://www.itdesk.info/en/databases-quiz/
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Terms of use:  

All freeware programs and services listed on the ITdesk Home Web site at ITdesk.info are the sole 

property of their respective authors. Microsoft, Windows and Windowsxx are registered trademarks 

of Microsoft Corporation. Other registered trademarks used on the ITdesk Home website are the sole 

property of their respective owners. If you have questions about using or redistributing any of the 

programs, please refer to the program license agreement (if any) or contact us via e-mail address 

info@itdesk.info.  

These sites contain links to other websites or resources. ITdesk.info team is not responsible for the 

text and/or advertising content or products that these sites/resources provide, as it is not 

responsible for any content that is available through them, nor the possibility of the inaccuracy of the 

content. Use the links at your own risk. Furthermore, the ITdesk.info team does not guarantee:  

- that the content on this website is free from error or suitable for any purpose,  

- that these websites or web services will function without error or interruption and  

   that they will be appropriate for your needs  

- that implementing such content will not violate patents, copyrights, trademark or other      

rights of any third party.  

If you disagree with the general terms of use or if you are not satisfied with the sites we provide, stop 

using this website and web services. The ITdesk.info team is not responsible to you or any third party 

for any resulting damages, whether direct, indirect, incidental or consequential, associated with or 

resulting from your use, misuse of this website or web services. Although your claim may be based 

on warranty, contract violation or any other legal footing, regardless whether we are informed about 

the possibility of such damages, shall be released from all liability. Accepting the limitations of our 

responsibilities is a necessary prerequisite of using these documents, webpages and web services. 

Please note that all stated software in this or other documents published at ITdesk.info is stated only 

for educational or exemplary purposes and that we in any case or manner do not prefer this software 

over any other similar software not mentioned in the materials. Any statement that would suggest 

that we prefer some software over other, mentioned or not mentioned in the materials, will be 

considered as false statement. Only open source software that allows users to become digitally 

literate without barriers, use the computer and participate in the modern information society has our 

direct and unconditional support. 

 

  

The website http://www.ITdesk.info/ was launched by a nongovernmental organization Open 

Society for Idea Exchange in order to actively promote the human right to free access to information 

and the human right to education.  

Feel free to copy and distribute this document, provided that you do not alter its contents!  

mailto:info@itdesk.info
http://www.itdesk.info/
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