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Preface 

Today's society is marked by a sudden growth and devlopment of the 

information technology (IT), which resulted in a great dependence of the 

society, in a broader sence, on the knowledge and competence of the person 

working in the IT area. And, despite the constant growth of the forementioned 

dependence, human right to education and information is not extended to the 

IT area. There is a presence of the problems which affect the society in whole, 

and create obstacles and distance people from the main reason and motivation 

for progress, the opportunity. Nowadays, to be a computer illiterate person 

means to be a person who is unable to participate in modern society, to be a 

person without an opportunity. Despite the fact that the European Commission, 

UNESCO, OECD and other relevant institutions have ackwnoledged the necessity 

and usefulness of the computer literacy, there are still griups of people with 

difficult access to the basic computer education (such as people with disabilities, 

people with learning difficulties, migrant workers, unemployed people, people 

who live in remote places without an access to the computer education). 

This handbook, along with all other materials published on the ITdesk.info web 

page, represent our contribution to realization and promotion of the human 

right to education and information in the IT area. We hope that this education 

will help you in overcoming the basic computer skills and with that hope, we 

wish you to learn as much as possible and therefore become the active member 

of the modern IT society.  

 

Sincerely yours, 

 
ITdesk.info team 

Expert review of 

Croatian version: 
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LIBREOFFICE 3.6 CALC APPLICATION 

Interface elements 

Picture 1. Interface elements 

1. Buttons for window manipulation present on the right-hand side of the title bar are 
used for maximization, minimization or closing the window.  

2. Document's title bar contains the information about the name of the document and 
the application in which the document was created.  

3. Tabs on the menu bar:  

 File – used for performing the basic file operations (saving, opening the existing 

file, creating a new one, printing...); 

 Edit – contains the file editing commands (copy, paste, cut, search...); 

 View – contains the commands for controlling the file display (zoom, show 

toolbars...); 

 Insert – contains commands for the insertion of elements in the file (header, 

footer, pictures); 

 Format – contains controls for formatting the file layout (styles and formatting, 

autoformat, ...); 

 Tools – contains various functions (spelling and grammar, adjustments, 

options...); 

 Data – contains functions for data management (filtering, sorting, range, 

validation...); 

 Window – contains controls for window display (share, freeze, new window, close 

window...); 

 Help – used for help with operating the application and for updating the new 
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version of the application etc. 

4. Standard toolbar contains tools that are required for working with files, data etc.  

5. Formatting toolbar contains text formatting controls. 

6. Formula Bar is used for displaying and editing data functions (sum, percentage and 
other functions).  

7. Row header indicating the row number, starting with 1. 

8. Column header indicating the column mark, starting with A. 

9. Cell selection. 

10. Menu for selected cells. 

11. Vertical navigation toolbar (horizontal navigation toolbar is placed at the bottom of 
the window). 

12. Worksheet menu, used for accessing the worksheets of the open document. 

13. Status Bar – displays the information about the current status of a program, such as 
the status of the items in the window of the program, the flow of the task that is 
currently being executed, or information about the selected item.  

 

BASIC OPERATIONS WITH SPREADSHEETS 

Column headers are marked with letters, due to easier visibility, and row headers are 
marked with numbers. Worksheets are made of columns and rows, and their basic unit is a 
cell. Each cell has its own coordinates (address) that are expressed with a column letter and 
a row number. The cell is selected by positioning on it (clicking on it).  To select more than 
one cell (cell range), after selecting the first cell, the left button of the mouse has to be 
pressed, held and dragged all the way to the desired cell range, and then released.   

Vertical and horizontal navigation toolbars (sliders) are used in reaching the desired 
location in the document. 

Status Bar displays the status of certain special/specific software functions. It is possible to 
adjust it according to the user’s needs.  

Name Box displays the current cell location in which the user is positioned.   

Formula Bar is used for entering the functions the user wants to use.   

 

Application launch 

Click on the Start menu, and then choose LibreOffice 3.6. folder from the All Programs 
menu. Then click on the LibreOffice Calc. application. A new workbook with a single 
worksheet will open. 
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It can also be opened via  shortcut, usually located on the Desktop, or by using the 
Search function. Simply enter the word 'calc' and choose LibreOffice Calc from the search 
result. 

 

Closing the application 

Application can be closed by clicking on the Close button, or by using the File menu and 
clicking on the Exit function, or by the Alt + F4 key combination. If the document is not 
saved, while attempting to close it, a dialog box will appear and you have to decide whether 
or not you want to save it.  

 

Opening workbooks 

Previously saved workbooks can be opened by clicking on the Open command, located in the 
File menu, and also via the dialog box that appears by selecting the desired workbook and 
clicking on the Open button. Dialog box for opening previously saved workbooks can also be 
accessed by the Ctrl+O keybard shortcut. 

For opening several workbooks at once, it is required to select all the desired workbooks 
from the dialog box (hold down the Shift key on the keyboard, if the workbooks are listed in 
sequence, or Ctrl if they are not) and then click on the Open button. 

 

Closing workbooks 

A workbook can be closed in several ways: 

 Click on the Close button that is placed on the right side of the Title bar; 

 Select Close command from the File menu; 

 Use the keyboard shortcut Ctrl+W. 

 

Creating a new workbook based on a default template 

Select the New command from the File menu and then go to the Spreadsheet command. 
The fastest way is to use the Ctrl+N keyboard shortcut, or to click on the toolbar command 
as shown in the picture below. A new workbook will open up.  



ITdesk.info – project of computer e-education with open access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Noncommercial-No Derivative Works 3.0 Croatia License  4/33 

 

Picture 2. New workbook command 

Also, select the command New from the File menu, then select Templates and Documents, 

and a new dialog box with templates will open. If you wish to download a template from the 

web, you can search the LibreOffice Templates by clicking on the link Get more templates 

online ... and save the new template to the computer.   

Saving a workbook to the specific file destination with the same or a new name 

Workbook is saved by clicking the Save command in the File menu. Saving a file can also be 

done by a combination of Ctrl+S keys on the keyboard or by clicking on the green arrow 

shaped icon on the Standard Toolbar  . 

To save a workbook under a different name, select the Save As command from the File 
menu. Enter a new file name in the in the dialog box that will appear, under File name. For 
each additional save, just click on the Save button on the Standard toolbar or use the Ctrl+S 
keyboard shortcut. 

Saving a workbook in another file format 

If you wish to save a workbook in another file format, choose the Save As command from 
the File menu. In the Save as dialog box, click on the Save As Type drop-down menu and 
choose the desired file format. If you wish to create a Template, choose Spreadsheet 
Template (*.ods). To save a workbook as a Microsoft Excel file, choose Microsoft Excel 
97/2000/XP/2003 (.xls) or if you want a newer version of MS Excel, choose Microsoft Excel 
2007/2010 XML (.xslx). 

Switching between open workbooks: 

 Moving the mouse over the application icon in the taskbar shows the Preview of the 
open folders, and by clicking on the thumbnails, you can move from one window to 
another; 

 By combination of  Alt+Tab keys; 

 Via Window → File name shortcut 
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Changing the default folder used for workbook storage 

If you want to change the default folder for the workbook storage, choose Tools  Options 
and LibreOffice  Paths from the dialog box, and then select MyDocuments and click on the 
Edit button. Choose the folder in which you wish to save your workbooks from the next 
dialog box.  

 

Help and Zoom functions 

Help function can be accessed via File  LibreOffice Help or by clicking on the icon  
which is located on the standard toolbar. After activating the help function, web browser 
with LibreOffice web page will open up. The fastest way of accessing the Help function is by 
using the F1 function key. 

Zoom dialog box is opened by clicking on the tool  located in the View menu. It is 
possible to choose between suggested zoom values or to enter your own value in the form 
of an integer between 0 and 100. Zoom dialog box can be opened by double clicking on the 
percentage value in the right corner of the status bar. To zoom immediately, you can also 

use the Zoom Slider   as well as the Ctrl key and the mouse 
wheel.  

 

Adjusting Toolbars 

Toolbars can be adjusted by selecting the View menu  Toolbars and then choose the 
desired toolbar. If you don’t want a certain toolbar to be seen, simply remove the checkmark 
next to it. There is a possibility of creating your own toolbar that can be adjusted to 
completely suit your needs. It can be done by choosing View  Toolbars  Customize.  
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CELLS 

INSERTION, SELECTION 

Only one piece of information is entered per cell. If you are, for example, making a table of 
personal information, enter a name in one cell, last name in the next one, address in the 
next one, and so on.  

Am empty row or column between the data range and formulas for some functions can lead 
to false results in some cases, and hence they should be avoided.  

When calculating, it is recommended to enter a blank row before entering the row for total 
amount for better visibility.  

Numbers are the most used data type and when entered in the cell, they are aligned to the 
right side. When you enter decimal numbers, use comma as the decimal separator (in 
Croatian settings). If you wish to enter a number or a formula as text, put an apostrophe in 
front of the number (i.e. '0041). The text is aligned to the left side of the cell.  

Date and time are remembered as numbers. When entering the date, a fullstop or a hyphen 
is used as separator (dd-mm-yy or dd.mm.yy – day, month, year). It is important to 
remember not to put any kind of a sign after year. Date is remembered as integer which 
represents time that has passed since 1st January 1900. When entering time, use colon as a 
separator (hh:mm:ss – hour, minute, second). Time is remembered as a decimal number 
that represents the number of seconds since midnight. They are aligned to the right side.  

Text represents everything that the application doesn’t recognize as a number, date or time. 
It aligns to the left side. In case the text is bigger than the size of the cell, and the adjacent 
cell is filled, only the part of the text that fits in the cell will be visible. The whole cell content 
can be seen in the formula input bar. If the text is often bigger than the cell, you should 
expand the cell width for better visibility.   

Cell can be selected:  

 By clicking on it – by pressing the left mouse button on the cell, the cell becomes 
active, which is indicated by a black frame. The content of the selected cell can be 
seen in the Formula Bar and the changes that are made (cell formation, input or 
deletion of content) will apply to that cell.  

 Arrow keys – after having positioned on a certain cell, move onto the next cell by 
using the arrow keys.  

 Drag and drop method – press and hold the left mouse button and drag the mouse 
to the desired cell range.  

 Ctrl key – while holding the Ctrl key, use the left mouse button to select desired cells; 
doing so selects the arbitrary non-adjacent cells.  

 Shift key – click on the starting cell, press Shift and using the arrow keys (or the 
mouse) to select the desired cell range; doing so selects the adjacent cells. 
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Rows and columns are selected by clicking on their header. If you wish to select more than 
one row or column, click on their header, hold the left mouse button and drag over the 
headers until the necessary number of rows or columns are selected.   

You can also use Ctrl (to select a non-adjacent rows or columns) and Shift (to select adjacent 
rows or columns) keys. 

To select the entire worksheet, click on an empty field in the top left corner of the worksheet 
(left of column A and above row number 1). A faster way of selecting the entire worksheet is 
the keyboard shortcut Ctrl + A. 

EDITING CELL CONTENT 

 

 Enter cell content - first select the desired cell and then enter text, number, date etc. 

 Add cell content - double-click the left mouse button on the desired position in the 

cell and enter additional content. 

 Modify existing cell content – select the desired cell and enter new content.  

If the entered content exceeds the cell width, it will be written across the adjacent cells if 

they are blank.  

Changing the position of the insertion point:  

 Tab key on the keyboard 

 Arrow keys on the keyboard 

 Clicking the left mouse button over the desired cell 

Undo function   is used when we want to go a step back, that is when we are unhappy 
with the result and wish to undo the last action. If you have made a mistake, for example, 
deleted a chart by mistake; using the Undo function, you can have the chart back in a 
second. It is a practical and often used function. It is located in the Standard Toolbar, and 
can also be run by the Ctrl+Z keyboard combination.  

Redo function  reverses the result of the Undo function. You may use it as many times 
as you have used the Undo function. You can run it via the Standard Toolbar or Ctrl+Y 
keyboard combination.   

Find and Find & Replace functions are used when we want to find and replace small 
amounts of data. Functions are located on the Edit tab. If you click on the Find function (or 
use Ctrl+F keyboard shortcut) at the bottom of the document, a dialog box will open in 
which you should enter the data you want to find. If you click on Find & Replace, a dialog 
box will open and you may enter the data you want to replace in the Search for field, and 
then enter the data you wish to input instead of the previous data, in the Replace with field.  
By clicking on the Find button, the search will result in the term that is next in line. If you 
click on the Find All button, the search marks all the terms in the workbook that match with 
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the searched term. Clicking on the Replace button, one (next) searched term will be 
replaced with the term you wanted to replace. If you continue to click on the Replace 
button, you will change every successive term. Clicking on the Replace All button will replace 
all of the terms in the document with the desired term. A faster way of opening the dialog 
box for term replacing is the Ctrl + H keyboard shortcut.  

SORTING CELL CONTENT 

 After the desired data range is selected,  click on the Data tab  Sort upon which a 
dialog box will open up where you should choose, using the drop-down menu, the 
value by which you want to sort the data.   

 On the standard toolbar, click the button: 

   if you want the values to be sorted ascending (from the least to most valuable, 

A-Ž) or  

  if you want the values to be sorted descending (from the most to least 

valuable, Ž-A). 

Text sorting 

Prior to using the function, it is necessary to establish the data type of the selected cell 
range. In this case, it is text. The selected alphanumeric string is sorted ascending i.e. from 
the smallest to the largest, or descending i.e. from the largest to the smallest.  

Text, which includes the numbers stored as text, are sorted in the following order:  

0 1 2 3 4 5 6 7 8 9 (space) ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J 
K L M N O P Q R S T U V W X Y Z a b c d e f g h i j k l m n o p q r s t u v w y z 

Text sorting is case-sensitive, and that is why the capitalized word will be sorted in front of 
the word with a small initial letter.  

Sorting numbers 

In cells that have numbers as the data type, sorting is done according to the given criteria – 
from the smallest to the largest number or vice versa.  

Sorting date and time 

In cells that have date or time as the type of data, sorting is done from the earliest to the 
latest date or vice versa, depending on the given criteria. 
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COPYING, MOVING AND DELETION OF CELL CONTENT 

We can copy a single cell, cell range, rows and columns, customized cell selection (Ctrl 
select), or the entire worksheet. Copied content can be copied on the selected place within 
the worksheet, between worksheets or workbooks.  

Copying via Edit tab 

Select the cell, cell range, column, row or a worksheet that you wish to copy and select the 
Copy command in the Edit menu. Then click on the cell (column, row, worksheet or 
workbook) in which you wish to copy and select the Paste command from the same menu.  

Copying via right-click method: 

1. select the content that you wish to copy and right-click on it, 
2. pop-up menu will open, from which you need to select the Copy command 
3. position the mouse to the location that you wish to paste the content (by clicking on 

it) and do a right-click, 
4. pop-up menu will open again, from which you need to select the Paste command. 

Copying by key combinations: 

Select the content that you wish to copy and press Ctrl+C on the keyboard. Click on the 
location where you wish to paste the content and press Ctrl+V.  

Copying by mouse: 

Select the cell, press the Ctrl button and click on the same cell again. When the cell turns 
blue, you can drag it to another location by clicking on it.  

Autofill function: 

Autofill is the pop-upest way to copy a cell content, entered formulas or cell formatting. It is 
necessary to click on the cell and position the mouse pointer in the cell’s lower right corner.  
When the pointer turns to a black cross, you need to click on it and drag it (up, down, left or 
right) until the cell content is copied to the desired locations in the worksheet. Autofill is also 
very practical in copying formulas. It is enough to enter the formula only once and using the 
Autofill, apply it to the adjacent cells.  

For example, enter the numbers 5 and 10 in the cells A1 and A2, select them and drag the fill 
handle (lower right corner) down – Autofill function will automatically continue the series 
(15, 20…). If you press Ctrl while using the Autofill function, the numbers 5 and 10 will be 
copied below (same goes for date and time). 

 

If you are using Autofill function with numbers, a number will be copied, and in combination 
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with the Ctrl key, it will be increased by 1. For multiple selected cells with numbers, Autofill 
function will continue the series, and in combination with the Ctrl key, numbers will be 
copied (same goes for date and time). 

Moving content by right-click method  

It is necessary to select the content that you wish to move and right-click on it. The pop-up 
menu opens up from which you should select the Cut command, position the mouse pointer 
to the location where you wish to move the content by clicking on it, and again click the right 
mouse button. The pop-up menu will open again, from which, this time, you have to choose 
the Paste command. 

Moving the content via Edit tab 

The cell content can be moved to a different cell, worksheet, or workbook. To move the 
content, use the Cut command. Select the cell, cell range, column or row that you want to 
move, and choose the Cut command from the Edit tab. Click on the cell (column, row, 
worksheet or workbook) to which you want to move the cut content and in the same menu, 
choose the Paste command.  

Moving the content by the keys combination  

Select the content that you want to move, and press Ctrl+X. Click on the location where you 
want to move, and press Ctrl+V keys combination.  

 
Ways of deleting cell contents 

Using the Edit tab 

Select a cell, cell range, column or a row that you wish to delete and from the Edit tab 

choose the  Delete Contents command . A dialog box will open, in which, in case you 
want to delete the complete content, select the Delete All command. 

Right-click method:  

Select the cells whose contents you want to delete, position the mouse pointer over them 
and press the right mouse button. The pop-up menu opens up, from which you need to 
select the command Delete Contents. This method removes only cell contents, while its 
formatting remains unchanged. 

This method can also be used to delete only the styles and formatting of cells, by selecting 
the cell and clicking the right mouse button, and then choosing the Clear Direct Formatting 
option.  
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Using keyboard keys:  

Select cells and press the Delete key or the Backspace key. This method removes only cell 

contents, while its formatting remains unchanged.  
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WORKING WITH WORKSHEETS 

ROWS AND COLUMNS 

Selecting a range of adjacent rows can be done in one of 3 ways: 

 Position the mouse pointer over the row header. Click on the initial row and, while 
holding the left mouse button, drag until you reach the desired row number. 

 Position the mouse pointer over the row header. Click on the initial row and, while 
pressing the Shift key on the keyboard, click on the last row that you wish to select. 

 Position the mouse pointer over the row header. Click on the initial row and, while 
holding down the Shift  key, use the arrows on the keyboard to select the desired 
rows.  

Selecting non-adjacent rows: 

Position the mouse pointer over the row header. Click on the initial row and, while holding 
down the Ctrl key, by clicking the left mouse button, select desired rows, columns or cells.  

Selecting columns is done in the same way as selecting rows.  

Selecting a range of adjacent columns is done in one of 3 ways: 

 Position the mouse pointer over the column header. Click on the initial column and, 
while pressing down the left mouse button, drag until you select the desired number 
of columns. Then release the mouse button. 

 Position the mouse pointer over the column header. Click on the initial column and, 
while holding down the Shift key, click on the last desired column. Then release the 
Shift key.  

 Position the mouse over the column header. Click on the initial column and, while 
holding down the Shift key, use the arrows on the keyboard to select the desired 
columns. Then release the Shift key.  

Selecting non-adjacent columns: 

Position the mouse pointer in the column header. Click on the initial column, press down the 
Ctrl key and by clicking the left mouse button, select desired rows, columns or cells. 

Inserting rows/columns 

First select the row or column beside which we want to insert a row or a column. From the 
Insert tab, choose commands Rows or Columns. A column is added to the right of the 
selected column, and a row is added below the selected row.  

We can also insert rows and columns by clicking the right mouse button, and we do it in the 
following manner: select the desired row or column and click the right mouse button. Select 
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the Insert command from the menu, and then a dialog box will open, in which we choose 
whether we want to insert only one cell and move the rest down, we do that by clicking the 
Shift cells down command, or insert only one cell and move the rest right, by clicking the 
Shift cells right command, or insert an entire row, by clicking the Entire row command, or 
insert an entire column, by clicking the Entire column command. 

Delete rows/columns 

Position the mouse pointer over the row/column header, and from the Edit tab, choose the 
Delete Cells command. 

or, 

open the pop-up menu by right clicking the mouse on the row/column header, and then 
choose Delete Rows or Delete Columns command. 

Changing row height/column width  

Position the mouse pointer over the row/column header, and right click to open the pop-up 
menu, and then, depending on whether it is row or a column, select the Row Height 
command or the Column Width command. Enter the desired height or width in the dialog 
box that appears.  

or, 
 
position the mouse pointer on the edge of the row/column header. When the pointer 
changes to:  

  , press and hold the left mouse button and drag the pointer until you reach the 
desired row height; 

  , press and hold the left mouse button and drag the pointer until you reach the 
desired column width. 

 
Setting the optimal height or width 

If the content of some cells in a row/column exceeds its size, not all data will be shown. In 
that case, we need to optimize its height and width, so that all content will be visible.  
Position the mouse pointer over the row/column header and, when the pointer changes to  

 , double-click the left mouse button.  
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FREEZING OR UNFREEZING ROW/COLUMN TITLES  

Freeze command is used when working with extensive tables that contain large amounts of 
data, and in order to ease the access to that data, it is quite practical to “freeze” some of the 
rows/columns of the table. If you are navigating through a long list of data, it is desirable to 
freeze a row or column with their names, so that you may know what information is 
contained in the list.  

First select the part of the worksheet that we wish to freeze (make constantly visible) and we 
do that in the following manner:  

 Freezing both rows and columns: select the cell that is located on the right side of the 
column that we wish to freeze and below the row that we wish to freeze, and choose 
the Freeze command on Window tab;  

 Freezing either multiple rows or multiple columns: select the column that is located 
on the right side of the column that we wish to freeze or select the row that is 
located below the row that we wish to freeze, and choose Freeze command from the 
Window tab.  

Freeze command is cancelled the same way, by clicking on the Freeze command and 
removing the checkmark beside it.  

 

WORKSHEETS 

Switching from one worksheet to another is done by clicking on the tab with the name of the 
worksheet on it, at the bottom of the application window. If you have not changed their 
names, they will be generic (Sheet 1, Sheet2…). Active worksheet tab (the worksheet in 
which we are positioned currently) is highlighted in relation to other worksheets, and its title 
is bolded. If there are a lot of worksheets (or they have long names), use the arrow buttons 
which are located in front of the worksheets to display the names of the worksheets. 

Inserting worksheets: 

 Click on the icon that is located next to the name of the last worksheet in the 

workbook at the bottom of the application window   . 

 Right click on the sheet in front of which we want to insert a new worksheet and 
choose Insert command from the pop-up menu, then a dialog box will appear, in 
which we choose where we want to insert a new worksheet, how many worksheets 
we want to insert, name of the worksheet etc. 

 On the Insert tab, click on the Sheet command. 

Deletion of worksheets: 

 Right click on the worksheet that we wish to delete and choose the Delete sheet 
command. 

 On Edit tab, select the Sheet command, and click on Delete. 
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For better orientation between worksheets, it is recommended to name the worksheets to 
suit the purpose, instead of leaving their generic names (Sheet 1, Sheet 2 etc.)  

Moving and copying worksheets: 

 Using the drag and drop method: Click on the worksheet you want to move, and pull 
the mouse pointer to where you want to position it.   

 Using the Edit tab: Choose the Sheet command and then click on the Move/Copy List 
command. A dialog box will open up, with options of copying or moving the 
worksheet in the same or another workbook, and also the option of choosing the 
order of the worksheet in relation to other worksheets. There is also a possibility of 
renaming the worksheet.  

 Using right-click: Right click on the worksheet and from the pop-up menu that 
appears, choose the Move/Copy Sheet command - the dialog box that was described 
in the previous paragraph will open up. 

Renaming worksheets: 

 Double click on the worksheet that you wish to rename. 

 Using the Format tab, find the Sheet command and click on Rename. 

 Right-click on the worksheet that you wish to rename, and choose the Rename Sheet 
command from the pop-up menu. 
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FORMULAS AND FUNCTIONS 

FORMULAS 

By entering a formula in a cell, we can calculate the values from other cells. It is important to 
remember that each formula starts with an equal sign (=) and can contain functions (i.e. 
SUM, ROUND), operators (i.e. +, *, >), references (i.e. D3) or a constant (eg. no. 2). Functions 
are default expressions (formulas) that perform some task. References (names) represent a 
cell address or a cell range (D3 or D3: D4). 

For example, if you want to calculate the product of two cells (i.e. D3 and D4), enter the 
formula =D3*D4 in the cell where you want to display the result. 

 

Picture 3. Examples of the seldomly used cells 

 Use the mandatory equal sign (=). 

 Enter references (names) of the cells you are using for the calculation (D3 and D4), or 
click on the cells. 

 Enter the mathematical operator that you want to use (*). 

Some standard errors 

Error #NAME? (error code: 525 )occurs when LibreOffice Calc does not recognize the text in 
the formula. It indicates that an identifier could not be evaluated:  

 no valid reference 

 no valid domain name 

 no column/row label 

 no macro 

 incorrect decimal divider 

 add-in not found. 

Error #DIV/0! (error code: 532) occurs when a number is divided by zero or empty cells. 
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Some other functions like VARP, VAR etc. may also return this error. 

Error #REF! (error code: 524) occurs with an invalid cell reference (it is possible that you 
deleted the cells that are referenced in the formula).  

Complete list of errors and errors code is published on this link: 
https://help.libreoffice.org/Calc/Error_Codes_in_Calc  

 

Relative addresses  

Addressing cells in LibreOffice Calc is quite relative – it is based on the relative address of a 
cell containing a formula, and cells whose addresses are in the formula. When copying the 
cell that contains a formula, its relative address, as well as the relative addresses of the cells 
contained in the formula, is changed. If you do not wish to type it over and over again, just 
copy the formula and it will automatically adjust to the cell in which it is being copied. 

Examples of relative cell reference: A1, B5, H3, etc.  

     

Cells B2 and C2 add up so that you enter the formula = B2 + C2 in cell D2. As the address of 
the cells is relative, simply copy the formula because it adjusts to the cell into which it is 
being copied. Select the cell D2, position the mouse pointer at the cell’s right edge, press and 
hold the left mouse button and simply drag down. The result is visible on the picture on the 
right. The formula in cell D2 is applied to cell D3. 

 

Absolute addresses 

There are other types of addressing - absolute addressing. It is used when you do not want 
the formula, while being copied, to adapt to the new cell, but you rather want to take 
advantage of just that specific cell address. Absolute address, as opposed to relative address, 
determines a fixed location of the cell. If you want to set the cell address as absolute, use F4 
key or type the symbol $ in front of the column letter and row number. 

An example of an absolute cell addressing is $B$11.  

https://help.libreoffice.org/Calc/Error_Codes_in_Calc
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In this case, you are using absolute addressing of the cell $B$11 and you do not want it to 
adapt to the new cell, while being copied. This ensures multiplication with always the same 
cell, i.e. with the number 1000. 

Examples of mixed-address: B$11 (relative address of the column B and absolute address of 
the row 11), $B11 (absolute address of the column B and relative address of the row 11). 

 

FUNCTIONS 

Functions are predefined expressions (formulas) that perform a calculation using values 
called function arguments. Each function has its own syntax:  
function_name (argument1; argument2; …). 

 
Methods of entering functions 

Direct entering of the function is a complex method because it implies the knowledge of its 
syntax. It is performed by positioning the mouse in the cell where you want to display the 
result, and entering the correct form of the function. After you have entered the name of 
the function, the parenthesis that follows along with the function argument opens, and a 
yellow note will appear indicating the arguments that are expected for the function.  If there 
is more than one argument per function, they are separated by semicolons (;), and if there is 

a criteria or some kind of text, they are placed inside quotations.  

If, for example, you want to calculate the sum of cells in the range (A1:A10), just write: 

 =SUM(A1:A10) 

 

distance (km) distance (m) 
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Function Wizard Button 

Click on the Function Wizard button in the Formula Bar.  

Via Insert tab 

On the Insert tab, by clicking on the Function command, a dialog box will open, in which we 
can choose the function; and for each function, enter arguments and choose the cell range. 

 

Via keyboard shortcut  

Click on the keyboard shortcut Ctrl + F2, and a dialog box with options for functions will 
open up. 

 
SUM Function 

SUM function adds all numbers in a particulate range of cells. Its syntax is 
SUM(number1;number2;...), where number1 and number2 represent the series of 
arguments (1-30) that we wish to add up. 

For example, if you want to calculate the sum value of the cell range (A1:A10), you should 
enter =SUM(A1:A10). 

 
AVERAGE Function 

AVERAGE function is used to calculate the arithmetic mean (average). Its syntax is: 
AVERAGE(number1;number2;...), where number1 and number2 represent the series of 
arguments (1-30) for which you want to determine the average. 

For example, if you want to calculate the mean of the cell range (A1:A10), you should enter 
=AVERAGE(A1:A10). 

 
MIN and MAX Functions 

MIN and MAX functions define minimum or maximum value in a given set of values. Their 
syntax is as follows: MIN(number1;number2;...) and MAX(number1;number2;...), where 
number1 and number2 represent a series of numbers (1-255) for which we wish to 
determine the minimum or maximum value. 

For example, if we want to calculate the minimum value of a cell range (A1:A10), you should 
enter =MIN(A1:A10). 
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ROUND Function 

ROUND function is used to round off the numberto a certain number of decimal places. Its 
syntax is: ROUND(number; count), where the number represents the number that is being 
rounded and count represent a number of decimal places to which it is to be rounded off. 

For example, if we want to round off the number in cell A1 to two decimal places, we should 
enter =ROUND(A1; 2). 

 
COUNT Function 

COUNT function is used for counting the cells that contain numbers and numerical values in 
the list of arguments. Its syntax is COUNT(value1; value2;...), where value1 represents a 
mandatory argument which contains cell references or cell range in which we wish to count 
the data, and value2 represents an additional argument, and so on. 

For example, if you want to count cells in a range (A1:A10), enter =COUNT(A1:A10). 

 
Logical function IF 

IF function is used when you want to check the veracity of a logical statement that has been 
set in the first argument, provided that: 

 if the claim is true – it will show the value that is given by a second argument or call 
another function; 

 if the claim is not true - the function returns the value of the third argument or calls 
another function. 

Its syntax is: IF(Test; Then_value; Otherwise_value), wherein: 

 the first argument Test –is any expression that can be evaluated as TRUE or FALSE; 

 the second argument Then_Value – is the value that the function returns if the  
logical_test is true; 

 the third argument  Otherwise_value  - is the value that the function returns if the 
logical_test is false. 

For example, you want to check if a phrase “some text” is added to the cell B3. Type the 
mandatory equal sign, followed by the IF function, and within the brackets state: 

 the first argument, in other words, the claim that you are testing – B3="some text"; 

 the second argument, in other words, the value that you want for function to return 
if the first argument is true - in this case you want it to show the word "true"; 

 the third argument, in other words, the value that you want the function to return if 
the first argument is false - in this case you want it to show the word "false". 
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You must not forget the separators (;) between the arguments. 

 

Picture 4. Example of the IF function 
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FORMATTING CELL CONTENT 

To determine the cell type, and therefore their representation, we use the Format Cells 
command. We can access the command in the following ways: 

 Via Format tab, and then by clicking on the command Cells; 

 Right-clicking on the cell we want to format, and then choosing Format Cells from 
the pop-up menu; 

 Using the keyboard combination Ctrl+1. 

A dialog box will open, from which we should choose the appropriate tab eg. Number tab. 

 

Picture 5. Format Cells dialog box  

When formatting numbers, we can choose the number of decimal places or turn on the 
display point as thousands separator. 

If we choose date as the data type, it can be displayed in multiple formats such as 29th July 
2010 or 29.07.10. 

In presenting the data as a currency, an appropriate number of decimal places and a 
currency symbol such as $100.00 is selected. 

Data can be displayed as a percentage for which also it’s possible to determine the number 
of decimal places.  
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On the formatting toolbar, there are tools for changing the font type and size; bold, italic or 
underlined display; and for changing the text color. If we wish to add some effect to the cell 
content (superscript, striketrough...), we need to click on the Format tab, then select the 
Cells command. This opens a dialog box Format Cells, in which we can select the Font Effects 
tab and select the desired effect.  

 
Font Type and Size  

 

Picture 6. Formatting Toolbar 

We need to select the cells in which we wish to change the font, for example from Times 
New Roman to Arial. We should click on the arrow next to the font name (in this case, Times 
New Roman), which opens the drop-down menu from where we select the font Arial. We 
can also change the Font size by entering it ourselves or selecting it from the drop-down 

menu  

or,  

right-click over the selected cells  Format Cells command  Font. 

If we want to display the cell content in bold, click on the Bold icon, or use Ctrl+B. For 
slanted view, click on the Italic icon or use Ctrl+I, and for the underlined display, click on the 
Underline icon or use Ctrl+U.  

By choosing the Background Color icon  , we can change the background color of the 
selected cell. If we click on the arrow next to the icon, we will open a drop-down menu with 
a selected color palette. If we wish to change the cell content color, click on the Font Color 

icon  

or,  

right-click over the selected cells  Format Cells command  Background.  

 

Alignment and edges 

If you want a longer text in a cell to be shown in several rows, use the Format tab  Cells, 
choose the Alignment tab and tick Wrap text automatically.  

We can access the command via CTRL+1. We must tick the Wrap text automatically in the 
Alignment group. 
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or,  

right-click over the selected cells  Format Cells command  Alignment tab  Wrap text 
automatically. 

Alignment command can be found on the formatting toolbar. Various options can be 
selected, regarding the position in which the cell content is placed in relation to its edges.  
Alignment group is located on the Format tab  Cells, and contains the commands: 

   Horizontal alignment – Align Left, Align Center Horizontally, Align 
Right, Justified, Filled, Distibuted 

  Vertical alignment – Top, Middle, Bottom, Justified, Filed, Distibuted 

  Text orientation  

   Cell content Indent – Decrease Indent, Increase Indent 

  Wrap Text – Wrap text automatically 

   Merge and Center Cells – Merge & Center Cells  

 

Cell merging and Centering Cell titles over a range of merged cells 

If you want to connect multiple cells and centrally align the text within them, use the Merge 
& Center Cells command. 

When you want to connect two or more adjacent cells (horizontal or vertical), use the Merge 
Cells command. Cell merging can be done in several ways: 

Via the formatting toolbar 

Click on the Merge & Center Cells command   

Right-click method 

We need to select the cells that we want to merge, position the mouse pointer over them, 
and right-click the mouse. Then we need to choose the Merge Cells command from the pop-
up menu.  

If we wish to merge two or more cells that contain data, only the content of the first cell will 
be saved, or in other words, the content of the leftmost cell in the range. 

Cell separation 

Cell separation can be done in the opposite way by selecting the cells that we wish to 

separate, and using the Merge & Center Cells command  again. 
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Right-click method: we need to select the cell that we wish to separate, position the mouse 

pointer over it and right-click. Select the Merge Cells command from the pop-up menu. 

Adding cell edges 

Click on the Cells command on the Format tab. A dialog box Format Cells will open. We can 
choose the type (internal, external, only the upper or lower limit), style (solid, double-dotted 
line) and color edges from the Borders tab.  

or, 

right-click the mouse button over the selected cells  choose the Format Cells command 
from the pop-up menu and click on Borders. 

Clicking on the arrow next to the icon  will open a drop-down menu in which we can, 
aside from the already mentioned options, choose the option of drawing the edges, which 
can be useful in creating more complex tables, or in deleting the borders.   
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WORKING WITH CHARTS 

Chart is a graphical representation of tabular data. Chart and tabular data are linked, i.e. 

changes in the table are reflected in the chart.  

CREATING CHARTS 

Tools for inserting charts are located on the Insert tab, under the Chart command. You need 
to select the cells that you want to display in the chart and click on one of the icons.  

 

Pictue 1. Chart Wizard dialog 

A chart can be created in four steps via Chart Wizard. Step number 1: select the chart type, 

such as a Column, Bar, Pie, Line, etc. Step number 2: select the range of data in the cells. 

These cells are automatically associated with that chart, and if you change the value in them, 

it will automatically change the look of the chart. Step number 3: further adjust the data 

series in a cell range. This step can be skipped. Step number 4: used for naming and marking 

the chart, and adding the chart legend. After completion of the chart, you will see a toolbar 

for graphs , on which you 

can adjust the chart performance. 

If you change your mind at any moment and wish to show the data in a Column instead of a 

Line, you should click on Chart Type icon  or right-click and choose the Chart Type 
command from the pop-up menu. 
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Move, resize and delete charts 

If you wish to move the chart to another location in the worksheet: 

• select the chart by clicking on it; press and hold the left mouse button on it; drag the 
cursor to the desired position, and release the mouse button, or 

• cut it using the command Cut (keyboard shortcut Ctrl+X) and paste it in the desired 
place using the Paste command (keyboard shortcut Ctrl+V). 

• right-click and select Position and Size, a dialog box will open in which you should 
select the X and Y coordinates for the position. 

To move the chart to a different worksheet, we need to cut it, using the Cut command 
(keyboard shortcut Ctrl+X) and paste it in the desired location using the Paste command 
(keyboard shortvut Ctrl+V) 

Changing the size of the chart 

 Right-click on the edge of the chart  Position and Size  adjust Width and Height 
in a dialog box, under the Size group.  

 Position the mouse in the corner of the chart, and when the mouse pointer changes 
its shape to a two-headed arrow, press and hold the left mouse button and drag until 
the desired size is achieved. 

Deleting charts 

Click on the chart and press Delete on the keyboard. 

 

EDITING CHARTS 

 

Changing the chart background color 

To change the chart background, first we need to select the desired chart by double clicking 

on the chart, or right-clicking on it and selecting the Edit command. Once the chart is 

selected, a toolbar for chart formatting will appear. If we click on the Format selection 

command, a dialog box will open in which we should click on the Area tab, and then select 

the color from the drop-down menu.  

Changing the color of the column, bar, line, pie slice in the chart 

Similar to changing the background color of the entire chart or area legends, the same 

procedures are used to change the colors of the column, bar, line, pie, etc. in the chart. Only 
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difference can be seen in step number 1: instead of selecting the entire chart, we need to 

specifically select columns (or one column – by double-clicking the left mouse button on the 

column), bar, line, etc. Then we should choose: 

 Format Wall - plot area on the chart 

 Format Title - the name of the legend or fields or coordinates 

We can also use, as mentioned above, Format Selection command from the Format tab. 

The text in the title, legend or axis is formated like any other text - when part of the chart 

(title, axis or legend) is selected, we select Font on the Format tab.   
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PRINT 

SETTINGS 

 

Picture 7. Print dialog box 

 

Printing a worksheet 

The Print command is located on the File tab. Clicking on it opens a dialog box for printing a 

document like showed on the image above. On the General tab, choose the printer that you 

want to use for printing, and then, clicking on the group Range and copies, select which 

worksheets you want to print (All sheets, Selected sheets, Selected cells), and in the Number 

of copies box, select how many copies of the document or workbook you want to print. 

Using the Page Layout tab, you can choose the number of pages per sheet, and set their 

schedule for printing. Using the Options tab, you can select the Print to File option if you 

want to store the data for later printing.    

By clicking on the icon  Print file directly (PRINTER) on the standard toolbar, you start 

the printing. If you want to check your document before printing, click on the Page Preview 

icon on the standard toolbar.  It will open the preview of your document, presented as it 

would be printed on the A4 size paper. A new toolbar for Print Preview will open,

on which you can change the margins, by clicking on the Margins command.  You can zoom 
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the document for a clearer preview. And if you want to close the print preview, simply click 

on the Close Preview command.   

Printing worksheet as a PDF 

There is an Export Directly as PDF icon which is located on the standard toolbar. Clicking 

on it opens a standard dialog box for saving files, where you should choose where you wish 

to save file and name your pdf file. 

 

Worksheet margins 

Clicking on the Page command, located on the Format tab, opens a formatting dialog box. 

Click on the Page tab, and in the group Margins, set the margin size. 

 

Worksheet orientation 

Clicking on the Page command, located on the Format tab, opens a formatting dialog box.  

Click on the Page tab, and in the group Paper format, choose the worksheet orientation 

either in Portrait (for vertical paper layout), or Landscape (for horizontal paper layout). 

 

Changing the size of the paper 

On the Format tab, click on the Page command to open up a dialog box for design. Click on 

the Page tab, and in the group Paper format, a large number of predetermined page sizes, 

such as Letter 21.59 x 27.94 cm,  A5 14.8 x 21 cm, etc. will appear on the Format drop-down 

menu.  

 

Header and Footer of the workshet  

On the Format tab, clicking on the Page command will open up a dialog box. Then, on the 

Header tab, click on Header On command by putting a check mark on it and, by doing that, a 

header is placed in the worksheet. Do the same again on the Footer tab, to insert the footer.  

If you want to edit the footer or header, click on the Edit button. That will open a dialog box 

for editing the header or footer. Three fields for entering the text will appear in the footer, 

on the left side, right side and in the middle. Those fields contain already set text alignment - 

the left field aligns the text to the left, the central aligns text centrally, and the right aligns 

the text to the right. To add text in the field, you should click on the field and enter text. To 

change or delete the text, you need to select the field again (it will select the text 

automatically), and enter a different text or click on the Delete key.  
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If you want to add a page number, or a title, or date and time, you can chose it under the 

Custom header options . Same goes for the footer.  

 

PREPARING TO PRINT  

Spelling tool is located on the Tools tab or on the standard toolbar, marked by the icon  . 

By running the tool, you will open a dialog box that offers suggestions of words that are not 
recognized, with the following options: 

 Ignore once - ignores the error and moves on to the next word; 

 Ignore all - ignores any repetition of misspelt words; 

 Change - changes the misspelt word with the selected word in the list of suggestions; 

 Change all - changing every misspelt word with the selected words in a list of 

suggestions. 

A word that is not in the dictionary can be entered by pressing the right mouse button and 
selecting the Add option. After that, the application will no longer recognize the word as 
misspelt. 

AutoSpellcheck is located on the standard toolbar, marked by the icon. If the icon is 
clicked, the application will automatically underline grammatically incorrect words with a 
wavy red line. Once the mistake is corrected, the line will disappear. 

 
Turning on and of the gridlines 

On the Format tab, you must click on the Page command. That will open a dialog box for 
design, in which you may choose the Sheet tab, and in the Print group, tick the field Grid. If 
you want to undo this action, you must untick the field.  

 
Displaying the row and column titles 

If while printing, you want to see the column and row titles, you should click on the Page 
command located on the Format tab. A formatting dialog box will appear where you need to 
tick the Column and row headers in the Print group. 
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If you have turned on the display gridlines, and the row and column headings; the table that 
you are printing will look like this:  

 

  Picture 8. The row and column grid titles is on 
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TERMS AND CONDITIONS  

 

Website www.ITdesk.info was launched by a non-governmental organization 

"Open Society for the Idea Exchange“ in order to actively promote human right 

for free access to information and human right to education.   

Feel free to copy and distribute this document, provided that you do not change 

anything in it! 

 

All freeware programs and services listed on the ITdesk Home Web site at ITdesk.info are the sole 
property of their respective authors. Microsoft, Windows, and Windowsxx are registered trademarks 

of Microsoft Corporation. Other registered trademarks used on the ITdesk Home Web site are the sole 

property of their respective owners. If you have questions about using or redistributing any program, 

please refer to: info@itdesk.info.   

___________________________________ 

These sites contain links to other web sites or resources. ITdesk.info team IS NOT responsible for the 

textual and/or advertising content or products that is provided on these sites/resources, as it is not 

responsible for any content that is available through them, nor the possibility of the inaccuracy of the 

content. Use links at your own risk. Also, ITdesk.info team does not guarantee:   

 that the content on this web site is free from errors or suitable for any purpose,   

 that these web sites or web services will function without error or interruption, 

 to be appropriate for your needs, 

 that implementing such content will not violate patents, copyrights, trademark or other rights 

of any third party. 

If you disagree with the general terms of use or if you are not satisfied with the sites we provide, stop 
using this web site and web services. ITdesk.info team is not responsible to you or any third party for 

any resulting damage, whether direct, indirect, incidental or consequential, associated with or resulting 

from your use, misuse of this web site or web services. Although your claim may be based on 
warranty, contract violation or any other legal footing, regardless of whether we are informed about 

the possibility of such damages, we shall be released from all liability. Accepting the limitations of our 

responsibilities is a necessary prerequisite for  using these documents, web pages and web services 

All listed software in this or other documents published on ITdesk.info is stated only for educational 

or exemplary purposes and that we do not prefer, in any case or manner, these software over other, 
similar software not mentioned in materials. Any statement that would suggest that we prefer some 

software over other, mentioned or not mentioned in materials, will be considered a false statement. 

Our direct and unconditional support goes solely to open source software that allow users to become 

digitally literate without barriers, use computer and participate in the modern information society.

file:///C:/Users/sisi/AppData/Local/Microsoft/Windows/Temporary%20Internet%20Files/Content.Outlook/GC5FI4CS/www.ITdesk.info
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