ITdesk.info - project of computer e-education with open access
- handbook for digital literacy

Databases – LibreOffice Base

Handbook

Author: Igor Filipović
Customized for the LibreOffice program:

Author:
Igor Filipović

Expert review:
Surojit Chakraborty

Title:
ITdesk.info – project of computer e-education with open access – Handbook for digital literacy

Subtitle:
Databases – LibreOffice Base, handbook

Translation:
Katarina Posilović

Proofreading:
Una Šijan

Cover:
Silvija Bunić

Publisher:
Open society for idea exchange (ODRAZI), Zagreb

ISBN:
978-953-7908-16-4

Place and year of publication:
Zagreb, 2013.

Education and Teacher Training Agency in Croatia has approved the use of this publication as official additional teaching resource in all the primary schools in Croatia

Class: 602-09/14-01/0418
Reg: 561-03-03/10-15-4
Zagreb, April 2015.

Copyright:
Feel free to copy, print and further distribute the whole or a part of this publication, including for the purpose of organized education, whether in public or private educational organizations, but only for noncommercial purposes (that is, free of charge to end users for use of the publication) and with a reference to the source (source: www.ITdesk.info – Project of Computer E-education with Open Access). Derivative works without prior approval of the copyright holder (NGO Open Society for Idea Exchange) are not permitted. For permission for derivative works please contact: info@ITdesk.info.
Preface

Today’s society is shaped by sudden growth and development of the information technology (IT) resulting with its great dependency on the knowledge and competence of individuals from the IT area. Although this dependency is growing day by day, the human right to education and information is not extended to the IT area. Problems that are affecting society as a whole are emerging, creating gaps and distancing people from the main reason and motivation for advancement-opportunity. Being a computer illiterate person today means being a person who is unable to participate in modern society, and a person without opportunity; and despite the acknowledged necessity and benefits of inclusive computer literacy from institutions like the European Commission, UNESCO, OECD, there are still groups of people having difficulties accessing basic computer education viz. persons with disabilities, persons with learning difficulties, migrant workers, unemployed persons, persons that live in remote (rural) areas where IT education is not accessible.

This handbook, combined with other materials published on ITdesk.info, represent our effort and contribution to the realization and promotion of human rights to education and information considering the IT area. We hope that this education will help you in mastering basic computer skills and with that hope we wish you to learn as much as you can, and therefore become an active member of modern ICT society.

Sincerely yours,

ITdesk.info team

Expert review of Croatian version:

ITdesk.info

EdukaCentar

USTANOVA ZA OBRAZOVANJE
1 DATABASE – BASIC CONCEPTS ...........................................................................4
  1.1 DIFFERENCE BETWEEN THE TERMS “DATA” AND “INFORMATION” .....................4
  1.2 DATABASE ORGANIZATION – TABLES, RECORDS, FIELDS .................................4
  1.3 EXAMPLES OF THE USE OF LARGE DATABASES .................................................4
  1.4 DATABASE ORGANIZATION ..................................................................................5
    1.4.1 WHAT DO TABLES CONTAIN AND TO WHAT DOES THE DATA IN THE TABLE APPLY ......5
    1.4.2 WHY SHOULD EACH TABLE FIELD CONTAIN ONLY ONE DATA ELEMENT (ONE TYPE OF
          INFORMATION) ........................................................................................................5
    1.4.3 CONNECTION BETWEEN DATA TYPES AND FIELD CONTENT ..............................6
    1.4.4 BASIC FIELD PROPERTIES ..............................................................................6
    1.4.5 PRIMARY KEY TERM ..........................................................................................7
    1.4.6 INDEX TERM AND WHAT IT PROVIDES FOR US ..............................................8
  1.5 CONNECTING TABLES – RELATIONSHIPS ..........................................................8
    1.5.1 WHY ARE THE TABLES IN A DATABASE CONNECTED .....................................8
    1.5.2 PRECONDITION FOR CREATING A RELATIONSHIP BETWEEN TABLES IN A DATABASE ....8
    1.5.3 RELATIONSHIP/CONNECTION TYPES BETWEEN TABLES ..................................9
    1.5.4 CREATING RELATIONSHIPS/CONNECTIONS BETWEEN TABLES ......................9
    1.5.5 IMPORTANCE OF PRESERVING REFERENTIAL INTEGRITY BETWEEN TABLES ..............10
    1.5.6 DELETING RELATIONSHIPS/CONNECTIONS BETWEEN TABLES ..........................10
    1.5.7 WHO CREATES, MANAGES, FILLS OUT AND MAINTAINS A DATABASE ..............11
2 DATABASE APPLICATION – LIBREOFFICE 3.6 BASE ........................................12
  2.1 ELEMENTS OF APPLICATION WINDOW ............................................................12
  2.2 BASIC TASKS: OPENING AND CLOSING THE APPLICATION OR ANY DATABASE ........13
    2.2.1 OPENING AND CLOSING A DATABASE ................................................................13
    2.2.2 CREATING A NEW DATABASE AND SAVING THE DATABASE TO A SPECIFIC LOCATION 14
    2.2.3 SETTING THE WORK ENVIRONMENT – TOOLBARS ........................................15
    2.2.4 HELP FUNCTION .............................................................................................16
  2.3 WORKING WITH A DATABASE ............................................................................16
3 TABLES ............................................................................................................18
  3.1 RECORDS ...........................................................................................................18
  3.2 DATABASE DESIGN ............................................................................................18
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.2.1</td>
<td>BASIC OPERATIONS</td>
<td>18</td>
</tr>
<tr>
<td>3.2.2</td>
<td>WORKING WITH FIELD SETTINGS</td>
<td>19</td>
</tr>
<tr>
<td>3.2.3</td>
<td>THE HAZARDS OF CHANGING DATA TYPES, FIELD SETTINGS IN A TABLE</td>
<td>20</td>
</tr>
<tr>
<td>3.2.4</td>
<td>PRIMARY KEY</td>
<td>21</td>
</tr>
<tr>
<td>3.2.5</td>
<td>FIELD INDEXING</td>
<td>22</td>
</tr>
<tr>
<td>3.2.6</td>
<td>CHANGING COLUMN WIDTH IN A TABLE</td>
<td>22</td>
</tr>
<tr>
<td>4</td>
<td>INFORMATION DISPLAY</td>
<td>23</td>
</tr>
<tr>
<td>4.1</td>
<td>BASIC OPERATIONS</td>
<td>23</td>
</tr>
<tr>
<td>4.1.1</td>
<td>FUNCTION TO SEARCH FOR A SPECIFIC WORD, NUMBER, DATE IN A FIELD</td>
<td>23</td>
</tr>
<tr>
<td>4.1.2</td>
<td>FILTERING TABLE AND FORM – WORKING WITH FILTERS</td>
<td>23</td>
</tr>
<tr>
<td>4.2</td>
<td>QUERIES</td>
<td>24</td>
</tr>
<tr>
<td>4.2.1</td>
<td>CREATING AND NAMING A QUERY FROM ONE TABLE</td>
<td>24</td>
</tr>
<tr>
<td>4.2.2</td>
<td>ADDING CONDITIONS TO A QUERY</td>
<td>27</td>
</tr>
<tr>
<td>4.2.3</td>
<td>FORMAT QUERY</td>
<td>28</td>
</tr>
<tr>
<td>4.2.4</td>
<td>RUN A QUERY</td>
<td>29</td>
</tr>
<tr>
<td>5</td>
<td>OBJECTS</td>
<td>30</td>
</tr>
<tr>
<td>5.1</td>
<td>FORMS</td>
<td>30</td>
</tr>
<tr>
<td>5.1.1</td>
<td>USING FORMS</td>
<td>31</td>
</tr>
<tr>
<td>5.1.2</td>
<td>FORM EDITING</td>
<td>32</td>
</tr>
<tr>
<td>6</td>
<td>REPORTS</td>
<td>33</td>
</tr>
<tr>
<td>6.1</td>
<td>REPORTS AND DATA EXPORT</td>
<td>33</td>
</tr>
<tr>
<td>6.1.1</td>
<td>NAMING AND CREATING A REPORT BASED ON A TABLE OR A QUERY</td>
<td>33</td>
</tr>
<tr>
<td>6.1.2</td>
<td>ADJUSTING DATA FIELDS POSITION AND TITLES IN A REPORT</td>
<td>34</td>
</tr>
<tr>
<td>6.1.3</td>
<td>DISPLAYING GROUPED FIELDS IN A REPORT</td>
<td>35</td>
</tr>
<tr>
<td>6.1.4</td>
<td>EDITING HEADER AND FOOTER</td>
<td>35</td>
</tr>
<tr>
<td>6.1.5</td>
<td>EXPORT A TABLE OR A QUERY RESULT</td>
<td>35</td>
</tr>
<tr>
<td>6.2</td>
<td>PRINT</td>
<td>37</td>
</tr>
<tr>
<td>6.2.1</td>
<td>SETTING PRINT LAYOUT</td>
<td>37</td>
</tr>
<tr>
<td>6.2.2</td>
<td>PRINT SETTINGS</td>
<td>37</td>
</tr>
<tr>
<td>7</td>
<td>GENERAL TERMS OF USE</td>
<td>40</td>
</tr>
</tbody>
</table>
1 DATABASE – BASIC CONCEPTS

A database is a structured collection of interrelated data. In a relational database, data is saved in tables.

1.1 DIFFERENCE BETWEEN THE TERMS “DATA” AND “INFORMATION”

Data is a fact that can be represented as audio, video, text or number. Data by itself may not be relevant, but if it is processed and put in a certain context, it takes on a meaning and becomes information. Information is that context – the meaning attached to the data.

As an example for data, we can take the sound of an alarm. If you listened to it out of context, it would be just an unpleasant and penetrating sound. After it was assigned the meaning “imminent danger”, it became (well known) information.

1.2 DATABASE ORGANIZATION – TABLES, RECORDS, FIELDS

A table is the most important database element. It is composed of rows and columns that contain information on a certain subject. A record in a table is displayed as a row (line) and contains information about a subject. Fields are individual record characteristics and are displayed as columns within a table. The type of data that can be entered in a field is specified by the data type (textual, logical, currency, numeric, date, binary...). Cells are the rectangular spaces where the rows and columns intersect, and where the date is entered.

Besides the type, within the fields we can also determine:

- Length;
- Format example – e.g. can be specified to add currency indicator to the amount;
- Default value – if nothing is entered, the specified value will be written in the field;
- Entry required – ensures that the value is entered in the field, otherwise it does not allow further action.

1.3 EXAMPLES OF THE USE OF LARGE DATABASES

- plane ticket reservations
- governmental institutions databases
- bank accounts
- patient data
1.4 DATABASE ORGANIZATION

1.4.1 WHAT DO TABLES CONTAIN AND TO WHAT DOES THE DATA IN THE TABLE APPLY

A **Table** is the most important database element. It is composed of rows and columns that contain information on a certain subject. Each table should contain data about one subject. e.g. the table **Customers** will contain the necessary data about customers.

A **Record** in a table is displayed as a row and contains information about a subject. e.g. all the information about one customer.

**Fields** are individual record characteristics and are presented as columns within a table. The type of data that can be entered in a field is specified by the data type (textual, logical, currency, numeric …). e.g. Name, Last Name, Address, City, Tel, E-mail...

![Image 1. Table records and fields](image)

1.4.2 WHY SHOULD EACH TABLE FIELD CONTAIN ONLY ONE DATA ELEMENT (ONE TYPE OF INFORMATION)

In Image 1. **Table records and fields**, you can see an example of a good table design where each field contains only one data element. Name is entered in one field, last name in another, street and number (address) in the third etc. On the other hand, a bad table example would be:

<table>
<thead>
<tr>
<th>ID</th>
<th>Name</th>
<th>Address</th>
<th>Tel</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Marko Marković</td>
<td>Ilica 23, 10000 Zagreb</td>
<td>013243544</td>
</tr>
<tr>
<td>2</td>
<td>Petar Perić</td>
<td>Borongajska 34, 43000 Bjelovar</td>
<td>043234967</td>
</tr>
<tr>
<td>3</td>
<td>Ivana Ivanic</td>
<td>Masarykova 2, 21000 Split</td>
<td>021324543</td>
</tr>
<tr>
<td>4</td>
<td>Mislav Martinic</td>
<td>Brozova 23, 10000 Zagreb</td>
<td>013454233</td>
</tr>
</tbody>
</table>

![Image 2. Bad design example](image)

There are two data elements in one field (first and last name in the Name field), and even three in another (street and number, city and zip code). The data is inflexible, making it very difficult to sort, and create queries and reports.
A better design example in comparison to the previous table would be this:

<table>
<thead>
<tr>
<th>ID</th>
<th>Name</th>
<th>Last Name</th>
<th>Address</th>
<th>City</th>
<th>Postal code</th>
<th>Area code</th>
<th>Tel</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Marko</td>
<td>Marković</td>
<td>Ilica 23</td>
<td>Zagreb</td>
<td>10000</td>
<td>01</td>
<td>3243544</td>
</tr>
<tr>
<td>1</td>
<td>Petar</td>
<td>Pećić</td>
<td>Borongajsa 34</td>
<td>Bjelovar</td>
<td>40000</td>
<td>043</td>
<td>234987</td>
</tr>
<tr>
<td>2</td>
<td>Ivana</td>
<td>Ivanić</td>
<td>Masarykova 2</td>
<td>Split</td>
<td>21000</td>
<td>021</td>
<td>234543</td>
</tr>
<tr>
<td>3</td>
<td>Miodre</td>
<td>Martinić</td>
<td>Brocova 23</td>
<td>Zagreb</td>
<td>10000</td>
<td>01</td>
<td>345233</td>
</tr>
</tbody>
</table>

Image 3. Good design example

With every data element in a separate field, it is easier to sort and create queries and reports.

1.4.3 CONNECTION BETWEEN DATA TYPES AND FIELD CONTENT

Field content is a particular data type within a table. It can be text, number, currency, date and time, yes/no, etc.

In the **Field name** column, you enter the data name you want to save, and in a column **Field Type**, you select which data type you want to select for that data.

In the **Description** field you can enter some notes about that field (rarely used).

1.4.4 BASIC FIELD PROPERTIES

Table fields have properties such as length, format and default value. These properties can be changed in the **Field Properties** in **Design View**.
Entry required – here you select whether you want the entry to be required or not

Length – e.g. preset to 100 text characters

Default Value – e.g. for Yes/No data type, default value is Yes

Format Example – e.g. several formats can be selected for date and time (usually – General, Long, Short, etc.)

A **Primary Key** is a field (fields), which clearly identifies each record saved in a table. Determination of primary keys is a very important part of the database design. It has to be taken into account that it is truly unique for each record. In Image 6, primary key is the ID field assigned with data type **AutoValue** – which means that during the entry, the system itself generates a new unique ID (number) for each new record.

Indexes are automatically assigned to primary keys, which significantly accelerate the search and data retrieval. Primary keys are often used to create relationships between tables.
1.4.6 INDEX TERM AND WHAT IT PROVIDES FOR US

Data location is stored in indexes. Table indexes are used on the same principle as indexes in a book – when searching for data, its location is looked up via an index. They are used to speed up the search and data retrieval. For tables with a small number of records, using indexes is not required, because speed improvement when searching or sorting is negligible. However, if there is a lot of data, by setting the appropriate indexes on certain fields, a significant search and sorting acceleration can be expected.

1.5 CONNECTING TABLES – RELATIONSHIPS

Often, databases consist of several tables. For example, an internet shop database could include, among other tables, Customers and Shipping tables. The mere fact that there can be multiple tables within a database suggests that the tables can be connected. The connection between tables within a database is called a "relationship".

1.5.1 WHY ARE THE TABLES IN A DATABASE CONNECTED

![Image 1. Relationship (1:n) between Customers and Shipping tables](image)

Relationships (connections) between tables are made through primary keys and on the principle of field equality. Tables are connected in order to make queries, reports and forms with data located in multiple tables. In Image 10, notice how the ID_customer field, which is the primary key of the Customer table, is connected with the ID_customer field from the Shipping table.

1.5.2 PRECONDITION FOR CREATING A RELATIONSHIP BETWEEN TABLES IN A DATABASE

To create a relationship (connection) between two or more tables, it is necessary to have fields that have the same data type (although fields do not need to have the same name) in those tables. In the image above, ID_customer fields are displayed, which are identical to the ones in the Customer table and in the Shipping table.
1.5.3 RELATIONSHIP/CONNECTION TYPES BETWEEN TABLES

Relationship types:

1 : N (One To Many) – One field in the relationship is the primary key. This is the most common relationship type.

1 : 1 (One to One) – Both fields in the relationship are primary keys. This is the most uncommon relationship type.

N : N (Many to Many) – In this relationship, a third table is created in which the primary key consists of two fields that are foreign keys from the connected tables.

1.5.4 CREATING RELATIONSHIPS/CONNECTIONS BETWEEN TABLES

On the Tools tab, the Relationships command needs to be selected.

To display the tables that you want to connect, it is necessary to click on the tool on the Design tab, in the Tools group.

The Add Tables dialog box will open (Image 8) in which you first select and then press the Add button to add the tables which are to be displayed within the Relationships pane.

A relationship can also be created via the drag and drop method (Image 9) by following the steps below:

1. position the cursor over the ID_customer field, which is the primary key of the Customers table;
2. press and hold down the left mouse button, and drag it to the ID_customer field in the Shopping cart table, and then release the mouse button;
3. the Relations dialog box (Image 10) will open up;
4. press the Create button to create a relationship.
1.5.5 IMPORTANCE OF PRESERVING REFERENTIAL INTEGRITY BETWEEN TABLES

The referential integrity ensures the integrity of all database records. By its application, the validity of the relationship between the tables is confirmed and accidental change or deletion of the related data is prevented.

Referential integrity is set in a variety of ways. If you want nothing to happen in the other table while you are changing the data in one table e.g. Customer, select No action in the group Update Options. If you want the other table to cascade or referentially change during the change, select the Update cascade option. If you want the places in the second table to be filled with Null values, select Set null. Same applies to the group Delete options, except that in this case, the values from the second table are set in case the data is deleted from the first table.

1.5.6 DELETING RELATIONSHIPS/CONNECTIONS BETWEEN TABLES

It is necessary to first select the relationship, and then:

- press the right mouse button and from the pop-up menu, select the Delete command, or
- press the Delete key on the keyboard.
1.5.7 WHO CREATES, MANAGES, FILLS OUT AND MAINTAINS A DATABASE

**Database designers** are experts who create professional databases.

**Database administrators** are responsible for database maintenance and functionality. Among their tasks is the determination of data access permissions for a particular category of users. Database administrators ensure database recovery in case of failure or major errors.

A **Database administrator** has the highest level of database user rights (access and manipulation). If required, he grants or withholds data access rights to the users.

The **Database administrator** is responsible for functioning, backup and database recovery in case of failure.

A **Database user** handles data entry, data maintenance and information retrieval.
2 DATABASE APPLICATION – LIBREOFFICE 3.6 BASE

2.1 ELEMENTS OF APPLICATION WINDOW

**Buttons to manipulate the window**, located on the right-hand side of the **title bar**; are used to maximize, minimize or close the window.

The **title bar** also contains information about the name of a database and an application in which it is made.

**Tabs:**

- **File** – is used to perform basic operations on the database (save or open an existing one, create a new one etc.).
- **Edit** – contains tools for editing a document and database objects, such as Copy, Paste, Delete, Rename, Edit.
- **View** – is used for switching views on tables or queries or forms, and for the selection of toolbars.
- **Insert** – is used to create database objects – tables, queries, forms and reports.
- **Tools** – contains commands for connections, administration, filtering, SQL query, macro commands and settings setup.
- **Window** – contains commands for opening a current window, closing a window and switching between open windows.
- **Help** – contains commands to access online LibreOffice help, and the command to check and update the current version of Base application.

**Standard toolbar** is used to access frequently used tools.

The database pane is located on the left side of the window and on it are listed all the database objects:

- Tables,
- Queries,
- Forms,
- Reports.
Bars for horizontal and vertical navigation (sliders) are used to navigate to the desired location.

Above the status bar, there is a form navigation bar.

Image 13. Form navigation bar

Status bar displays information about the type of view of the object in the database.

### 2.2 BASIC TASKS: OPENING AND CLOSING THE APPLICATION OR ANY DATABASE

#### Running an application

Application can be run in several ways:

- On the Start menu – click on All Programs and in the LibreOffice 3.6 folder select Libreoffice Base.
- Using the Search function – enter the word 'base' and from the search results select Libreoffice Base.
- By double-clicking the shortcut to the program which is usually found on the computer desktop.

#### Closing an application

Application can be closed in several ways:

- By clicking on the Close button located on the title bar.
- Via the File tab, by selecting the Exit function.
- By the combination of keys: Alt + F4.

#### 2.2.1 OPENING AND CLOSING A DATABASE

**Existing database is opened:**

- by the Open command on the File tab;
- using the keyboard shortcut Ctrl + O;
- by double-clicking the left mouse button on the database icon;
- by right-clicking on the database icon and selecting the Open command.

When closing a database, it is easiest to use the Close option located on the File tab.
2.2.2 CREATING A NEW DATABASE AND SAVING THE DATABASE TO A SPECIFIC LOCATION

Creating a new database

On the File tab, the New command is selected. To create a new blank database it is necessary to select the Database template, the dialog box Database Wizard will open:

This dialog box opens every time you run Base application. In this dialog box, you can create a new database, open an existing one, or connect to an existing database.

To create a new database, select Create a new database. As you proceed, you will be asked to enter the name of the new database and the selection of directory to save the same. Click Save, and the new database will be created.

Saving a database

Saving a database is done by clicking on the Save command on the File tab. You can also use the key combination Ctrl + S.

Before saving the database, it is necessary to close (and save) all database objects. If you did not do this, a dialog box will appear with a warning (Image 15).
If you did not save the objects, do it now.

In case that you are saving the table for the first time, the **Save As** dialog box will appear, in which you need to specify the table name.

After closing and saving all of the objects, you can save the database.

### 2.2.3 SETTING THE WORK ENVIRONMENT – TOOLBARS

**Setting the Standard Toolbar**

The **Standard Toolbar** is used for a quick access to the most often used tools. On the **View** tab, it is necessary to click on **Toolbars** and select the **Customize** command. The **Customize** dialog box opens up where, depending on your needs, the desired tools can be added and the unnecessary tools removed.
2.2.4 HELP FUNCTION

The Help function can be accessed via the Help tab. By selecting the LibreOffice Help command, an internet browser opens with an available list of help topics. In the upper right corner there is a text box Search, in which you can enter a term that you want to explore.

The Help function can also be accessed by clicking on the icon 🔄, which is located on the Standard Toolbar or by the function key F1.

2.3 WORKING WITH A DATABASE

Opening a table

In the Database pane, it is necessary to click on Tables.

In the Tasks window in the upper part, there are options for creating a new table in Design View or via Table Wizard, or for creating a view.

In the Tables window in the lower part, the saved tables from the current database are displayed.

Saving a table (query, form, report)

Saving any database object (table, query, form, report) is done by selecting the Save command on the File menu.
Closing a table, query, form, or report

A table is closed by pressing the Close button. The keyboard shortcuts Ctrl + W and Ctrl + F4 can also be used.

Deleting a table, query, form, or report

Within the database pane, it is necessary to select the object (table, query, form, report) that you want to delete and:

- press the right mouse button and select the Delete command from the pop-up menu;
- on the Edit tab select the Delete command;
- select the object and click the Delete button.

Navigate between records and fields in a table, query, or form by:

- pressing buttons on the form navigation bar;
- pressing the keys: up, down, left, right, PageUp, PageDown, Tab, Home, End;
- clicking over the field, or on the gray border at the left side of the record.

Sorting records in a table, query, or form in an ascending or descending order, numerically and alphabetically

By pressing the button on the Standard Toolbar, the dialog box Sort Order for the selection of column, and of the order by which you would like to sort (ascending or descending) will open.

- By selecting a column for which you want to sort the data, then clicking on the button on the Standard Toolbar, the data will be sorted in Ascending order.
- If you click on the button , you will sort the data in Descending order.
3  TABLES

3.1  RECORDS

Adding records in a table

It is necessary to click on the record marked with an asterisk and enter the data – it cannot be entered in the ID_customer field, because it was assigned with the AutoValue data type (the system will automatically generate a number).

![Image 21. Adding a new record](image)

Deleting records in a table

It is necessary to select the row that you want to delete, and when a green arrow appears and the row turns blue, press the Delete key.

Changing data in a record

It is necessary to mark the data or part of the data that you want to change, delete the entry with the Delete key, and enter new data. You can also select the entire record and enter new data.

Deleting data in a record

It is necessary to select the data or a part of it, and press the Delete key.

3.2  DATABASE DESIGN

3.2.1  BASIC OPERATIONS

Creating and naming a table

A table can be created via the Create Table in Design View command (see Image 19)
On pressing the **Close** button, a dialog box appears asking whether you want to save the table. If you reply “yes”, the **Save As** dialog box appears in which you enter the table name.

### Table design

After the **Field Name** is specified, it is necessary to click to the right of it in the **Field Type** column, and in the drop-down menu select the appropriate data type.

![Image 22. Table design – specifying field type](image)

**Data types in the fields** (often used):

- **Text** – accepts text and numeric characters;
- **Number** – accepts exclusively numbers;
- **Date/Time** – date and time entry;
- **Yes/No** – logical values such as True and False;

### 3.2.2 WORKING WITH FIELD SETTINGS

#### Changing field settings

**Length** – if a text is assigned as the field data type, this is where you enter the field size.

![Image 23. Specifying the field size](image)

**Default Value** – via this property, the value that Base will automatically enter in a table is specified (e.g. in **Image 24** – if nothing is entered, the number of pieces of some product will be displayed as 0).
Decimal places – this specifies how many decimal places numbers with a floating point will have. In our case, two decimal places after the comma are specified.

Format example – if a date is assigned to the field as a data type, clicking on the button opens the Field Format dialog box for the selection of field format, and one of the available displays is selected.

3.2.3 THE HAZARDS OF CHANGING DATA TYPES/ FIELD SETTINGS IN A TABLE

For example, if you try to type some text in a Number field – the system will automatically replace that value with 0, because only numeric values are entered in the Number field.
Changing the data type and its attributes should be handled carefully, because it may lead to data loss and impairment of database integrity.

3.2.4 PRIMARY KEY

The Primary key is a field (fields) that uniquely identifies each record saved in a table. Specifying primary keys is a very important part of designing the database and the fact that it is indeed unique for each record should be taken in account. In Image 26, a primary key is the field ID_customer to which AutoValue is assigned as data type – which means that the system itself assigns a unique value to ID_customer (number) for each new record.

![Image 26. ID_customer field – primary key of Customer table](Image)

Defining a field as a primary key (via Design View)

Before defining the primary key, it is necessary to switch to Table Design View, select the field (ID_customer) that will be defined as the primary key and then right-click on the gray area to the left of the field name.

![A pop-up menu will appear, in which you will select Primary Key. That will then be marked with a check mark as a confirmation that the primary key is turned on in this field.](Image)

After the activation of the primary key, a yellow key will be visible before the field ID_customer (Image 27).
Removing the primary key

You can remove the primary key by clicking the right mouse button on the yellow key, and remove the check mark from **Primary Key** in the pop-up menu by clicking on it. As a confirmation, the yellow key in this field will no longer be visible.

### 3.2.5 FIELD INDEXING

Indexes are automatically assigned to primary keys and double records are not allowed. The field’s index property (**Indexed**) is defined in the **Tools** tab:

By placing a check mark in the field **Unique**, you specify that the field cannot contain duplicate values in any of the two rows.

### 3.2.6 CHANGING COLUMN WIDTH IN A TABLE

To change the column width in a table, first you need to be in the **Table Data View**, and then right-click on the field header whose width you want to change. A dialog box will appear, like shown in the *Image 29*. In the **Width** field, you will enter the desired value. Otherwise you can put a check mark on the **Automatic** field, and then the column width will adjust to the widest value in the column.
4 INFORMATION DISPLAY

4.1 BASIC OPERATIONS

4.1.1 FUNCTION TO SEARCH FOR A SPECIFIC WORD, NUMBER, OR DATE IN A FIELD

The Find Record function is used when you want to find some data. This function is located on the Table Data bar (or the Form Navigation bar) under the icon. It can also be accessed via keyboard shortcut: Ctrl + F.

![Record search](Image 30. Record search)

You should enter requested data in the Text text box and press the Search button. You can choose to search by the values NULL and not NULL.

Options for selecting where you want to search for the data are located in the Where to search group. For example, you can search all the columns in a table or each column individually.

In the Settings group, you can select additional options for a more precise search, such as Match case which will ensure that upper and lower case are taken into consideration during the search.

4.1.2 FILTERING TABLE AND FORM – WORKING WITH FILTERS

A filter is used to restrict the data display to only certain records, while setting a certain condition. Data that do not meet this condition will not be displayed.

The Standard Filter icon is located on the Table Data bar (or Form bar).
Clicking on it opens up the **Standard Filter** dialog box where you have to specify the filtering criteria. It is necessary to select **Field name** from the menu which is to be filtered (eg. **Name**), then the **Condition** (eg. **Equals**), and specify the **Value** (eg. **Marko**). In the same way, one can add more filters for more refined filtering by selecting the following (field name, condition and value) in the next row.

**Removing a filter from a table/form**

Removing is done by clicking on the **Remove filter** button.

### 4.2 QUERIES

**What purpose do the queries serve?**

**Queries** in LibreOffice base application are used for data (that have met a certain condition) extraction from a table. They can also serve to change the data, and for data analysis. Also, query results can be data sources for forms and reports.

#### 4.2.1 CREATING AND NAMING A QUERY FROM ONE TABLE

**Using a specific search criteria**

Queries can be created with the help of **Query Wizard** or in **Design View**. With Query Design we specify the data with which we want to work with, tables or queries which this data is from and we define the criteria.

**Query Wizard** and **Query in Design View** can be found on the main window of our database on clicking on **Queries** in the **Database pane**.
To run a simple query from one table it is necessary to click on **Create Query in Design View**... and then select which table will be used (previously saved queries can also be used).

For instance, to select the table **Furniture**, click on it, then click **Add**, and finally click **Close**:

<table>
<thead>
<tr>
<th>ID</th>
<th>Description</th>
<th>Type</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Louis XV table</td>
<td>Table</td>
<td>25,000.00 HRK</td>
</tr>
<tr>
<td>1</td>
<td>Quartetto tables</td>
<td>Table</td>
<td>3,000.00 HRK</td>
</tr>
<tr>
<td>2</td>
<td>17 century Spoon-Back</td>
<td>Chair</td>
<td>4,500.00 HRK</td>
</tr>
<tr>
<td>3</td>
<td>Salt Back Shaker</td>
<td>Chair</td>
<td>1,800.00 HRK</td>
</tr>
<tr>
<td>4</td>
<td>Tallboy</td>
<td>Cabinet</td>
<td>1,250.00 HRK</td>
</tr>
<tr>
<td>5</td>
<td>Lowboy</td>
<td>Cabinet</td>
<td>2,500.00 HRK</td>
</tr>
<tr>
<td>6</td>
<td>Linen-Press</td>
<td>Cabinet</td>
<td>3,500.00 HRK</td>
</tr>
<tr>
<td>7</td>
<td>Games-Table</td>
<td>Table</td>
<td>4,800.00 HRK</td>
</tr>
</tbody>
</table>

After that, we select the fields that we want to query. The easiest way to do so is with the help of the drag and drop method, and we can also do so double-clicking on the required
field. In this case we added Description, Type and Price. The table at the bottom of the query window will now have three columns as shown below.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Type</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alias</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table</td>
<td>Furniture</td>
<td>Furniture</td>
<td>Furniture</td>
</tr>
<tr>
<td>Sort</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Visible</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Function</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Criterion</td>
<td></td>
<td>‘Chair’</td>
<td></td>
</tr>
</tbody>
</table>

Image 35. Adding fields

Now we can also add certain criteria, provided that the text criteria are in quotation marks. For this example, we have set that our query prints all the furniture that is ‘Chair’.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Type</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alias</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table</td>
<td>Furniture</td>
<td>Furniture</td>
<td>Furniture</td>
</tr>
<tr>
<td>Sort</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Visible</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Function</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Criterion</td>
<td></td>
<td>‘Chair’</td>
<td></td>
</tr>
</tbody>
</table>

Image 36. Setting criteria

And this is the result of the query:

<table>
<thead>
<tr>
<th>Description</th>
<th>Type</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>17 century Spoon-Back</td>
<td>Chair</td>
<td>4,500.00 HRK</td>
</tr>
<tr>
<td>Salt Back Shaker</td>
<td>Chair</td>
<td>1,800.00 HRK</td>
</tr>
</tbody>
</table>

Image 37. Query result

**Using a specific search condition**

To run a query from two (or more) tables using a specific condition, we follow all the steps presented in the example above, just using two (or more) tables instead of one. In addition, the tables that are used must be connected (have a relationship) with one another. For example, there is a *Customer* table (which has the fields: *ID, Name, Last Name, City, Tel, Address*), and a *Customers Interests* table (which has *Product ID, Customer ID* and *Product*).
The tables are connected via the Customer ID field. You need to create a query using the Name, Last Name and Products field.

So, in the first step, you add the tables Customer and Customers Interests. In the second step, using the drag and drop method (or double-click), you add the fields that you want (Name, Last Name from the Customer table and Products from the Customers Interests table), and you run the query.

4.2.2 ADDING CONDITIONS TO A QUERY

Using one or few of the comparative operator(s): = (equal to), <> (different from), < (less than), <= (less than or equal to), > (greater than), >= (greater than or equal to)

We can add operators to criteria. For example, from the Furniture table, a query that will display all the prices greater than 3,000 can be created using the “>” operator.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Type</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alias</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Table</td>
<td>Furniture</td>
<td>Furniture</td>
<td>Furniture</td>
</tr>
<tr>
<td>Sort</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Visible</td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Function</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Criterion</td>
<td></td>
<td>&gt; 3000.00</td>
<td></td>
</tr>
</tbody>
</table>

Image 38. Query that displays all the furniture greater than 3,000

Query result is as follows:

<table>
<thead>
<tr>
<th>Description</th>
<th>Type</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Louis XY table</td>
<td>Table</td>
<td>25,000.00 HRK</td>
</tr>
<tr>
<td>17 century Spoon-Back</td>
<td>Chair</td>
<td>4,500.00 HRK</td>
</tr>
<tr>
<td>Linen-Press</td>
<td>Cabinet</td>
<td>3,500.00 HRK</td>
</tr>
<tr>
<td>Games-Table</td>
<td>Table</td>
<td>4,800.00 HRK</td>
</tr>
</tbody>
</table>

Image 39. Query result

Also, other conditions can be added by using the other comparative operators: = (equal), <> (different from), <= (less than or equal to), >= (greater than or equal to).

Using one or few of the logical operator(s): AND, OR, NOT

We can use logical operators: AND, OR and NOT in a query.

For example, NOT "Chair" criteria on the Type field will display all furniture except chairs. "Chair" OR "Cabinet" will display all the chairs and cabinets.
4.2.3 FORMAT QUERY

Adding, changing or deleting criteria

To change or delete criteria you only need to select it and then change it by typing, or delete it by using the Delete key.

To add more conditions, the OR logical operator can be used or the “Or” field, as shown in the image below.

![Image 40. Setting more conditions using “Or” field](image1.png)

By setting this condition, the query will display all chairs and cabinets.

![Image 41. Setting a condition using OR logical operator](image2.png)

Just like in the previous case, this query displays all the furniture whose type is a Chair or a Cabinet.

Adding, deleting, moving, hiding, unhiding fields

We can add, delete, move and hide/unhide fields in the Design View. Adding is already explained, while to delete a field, it only has to be marked i.e. position the mouse cursor on the header and when the column turns blue, press the right mouse button, and select the Delete command.

To move a field, it needs to be selected first. Then you need to press the left mouse button, and drag and drop the field to the left or right side.
To hide/unhide a field, just mark (or clear) the Visible check box.

<table>
<thead>
<tr>
<th>Visible</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
</table>

Image 42. Visible check box

### 4.2.4 RUN A QUERY

A query is run from the Edit tab, under the Run query command, or by pressing the F5 key, or with a click on the Run Query button.
5 OBJECTS

Database objects

A table is the most important element of any database, it is used for data storage. It consists of records (that are) presented as rows and fields, which are presented as columns.

Queries provide an overview of one or more tables, enable sorting and selecting data, adding and deleting data etc.

Forms are used to enter, delete or modify data in tables with data seen in graphical representation, and not in tables.

Reports are used when preparing data for printing, and represent the database output.

Macros are used to automate actions or procedures. They define actions that are executed in response to specific events (e.g. we run the query by pressing a button to which we have assigned the macro).

5.1 FORMS

A form is a database object whose role is to interact with the user. The user does not see the table, but the forms that display the records, which are in this way more easily viewed and edited.

Creating and naming a form

The form can also be created via Use Wizard to Create Form or Create Form in Design View. All the fields in the design should be manually added and formatted as desired.

Image 43. Form Wizard
Wizard for creating form

Wizard is run from the main window by clicking on Forms on the Database pane, and then selecting the Use Wizard to Create Form. A new window representing a new form will open. Along with it, a dialog box titled Form Wizard will open, using which you can create a form in a few steps.

Step 1: Select a table or a query that you want to work with.

Step 2: By using the button $>$, you can insert fields that you want to work with and click Next at the end.

Step 3: If you want to add a subform that displays data from another table that is related by a primary key, set a tick in the Add Subform command. Click Next.

Step 4: Select fields layout by selecting one of 4 offered possibilities. Click Next.

Step 5: Select the type of data input. Click Next.

Step 6: Select layout style of your form. Click Next.

Step 7: Enter the name of the form. Click Finish.

5.1.1 USING FORMS

For adding new records

One of the advantages of using forms is the ability to enter new records without using a table. By using the New Record button a new record is inserted.
Deleting records

Once you are positioned on the record that you want to delete (while you are in a window form), click on the Delete Record button [ ] which is located on the Form Navigation bar.

Adding, editing or deleting data in forms

Old data in the forms can be modified and deleted, and new data can be added. It is necessary to select the record you want, mark the entry field and enter new data, or delete the old ones with the Delete button.

5.1.2 FORM EDITING

Adding and changing the text in the form labels can be done in Design Mode. Clicking on the thumbnail [ ] , you switch to design mode.

It is necessary to double–click the left mouse button on the text in the label or control. The Properties dialog box will open, where you can manually adjust the properties of the selected control. To change the name of the label, under the Label property enter the name of the label.

![Image 47. Marking the text in the label](image)

Adding control on the form

To add a control to your form, it is necessary to click on the control that is located on the Form Controls toolbar.

Then you indicate where you want to set the control on the form, by pressing the left mouse button on it and dragging it to the desired location. When you release the left mouse button, a new control will be displayed. Double–clicking on it, you can change its properties.
6 REPORTS

6.1 REPORTS AND DATA EXPORT

Simply put, a report prints a list of table records or a query. For this purpose, the Print command can be used, but if you want to achieve a more professional look, you can use reports.

6.1.1 NAMING AND CREATING A REPORT BASED ON A TABLE OR A QUERY

From the Database pane (located on the left side of the application window as displayed in Image 12), select Reports. As you can see in Image 48, you can design your own report from the beginning via Create Report in Design View or simply choose Use Wizard to Create Report.

In Design View, you start the design from the beginning - you add fields by yourself, via Add field dialog box and arrange them as you wish using the "drag and drop" method.
By selecting the **Use Wizard to Create Report** option, a dialog box **Report Wizard** appears, which takes you through the design in six steps, by which you define all the elements *(Image 50)*.

6.1.2 **ADJUSTING DATA FIELDS POSITION AND TITLES IN A REPORT**

Changing data fields position and titles in a report is easily done in **Design View** *(Image 49)*. We select the field that we want to move or delete, and when the cursor in a shape of four arrows (up, down, left, right) appears, we move the field to wherever we want.
6.1.3  DISPLAYING GROUPED FIELDS IN A REPORT

Reports can display certain grouped fields. If we use the Report Wizard, in the third step we determine if and which fields do we want to group. If we are using the Design View, we select the Sorting and Grouping button. The eponymous dialog box (displayed in Image 51) appears, via which we select, from the drop-down menus, which fields will be grouped and how will they be sorted (ascending or descending).

Image 51. Sorting and Grouping dialog box

6.1.4  EDITING HEADER AND FOOTER

As with forms, adding and editing text in the header and the footer of the report is most easily done in the Design View. Again, just select the text in the header or footer; delete it or enter a new one. Grouped data can have their own special header.

6.1.5  EXPORT A TABLE OR A QUERY RESULT

Export a table in a spreadsheet (.xlsx) or a text file (.txt)

On the File tab, one of the offered options is the Report Output Format, on which if we position the mouse, we can see that there are two offered output forms of the report: data export to a Text Document or a Spreadsheet Document.

Image 52. File tab – Report Output Format command
Reports export to a PDF format can be done in two ways. The Export as PDF... command is located on the File menu, and the Export Directly as PDF command is located on the toolbar.

Image 53. File menu – commands for data export

Export table to an XML data file (.xml)

To export the data in a different format, it is necessary to use the Export... command which is located on the File menu (Image 53). A dialog box Export opens, via which the name, the format and the location to which the file will be saved (e.g. .xml or .html), are selected.

Image 54. Export dialog box
6.2 PRINT

6.2.1 SETTING PRINT LAYOUT

On the File menu, it is necessary to select the Print or the Print Preview command. These commands are also located on the Standard Toolbar (Image 55).

Calling the Print command:

- via the File tab, by selecting the Print command;
- via the key combination Ctrl + P;
- via the button on the toolbar (exists also in the Print Preview window).

6.2.2 PRINT SETTINGS

Print range:

- All – this option is used to print the entire report;
- Pages – prints a default page range;
- Selection – prints only marked records of a report.

Number of copies:

If you want to print a report in a few copies, specify the number of copies in the Number of copies field.
Image 56. Print dialog box
This handbook is intended for learning in conjunction with materials published on the following links:

* **Script:**
  [www.itdesk.info/Microsoft Access 2010 notes.pdf](http://www.itdesk.info/Microsoft Access 2010 notes.pdf)

* **Video-presentations displaying work in OpenOffice Base are on the following links:**

* **Sample exam for 5th module is published on the following link:**
  [www.itdesk.info/sample exam/sample exam module 5.pdf](http://www.itdesk.info/sample exam/sample exam module 5.pdf)

* **Video-presentation displaying the solution of the module 5 exame sample is on the following link:**

* **Quizzes that users solve themselves:**
7 GENERAL TERMS OF USE

The website http://www.ITdesk.info/ was launched by a nongovernmental organization „Open Society for Idea Exchange - ODRAZI“ in order to actively promote the human right to free access to information and the human right to education.
Feel free to copy and distribute this document, provided that you do not alter its contents!

All freeware programs and services listed on the ITdesk Home Web site at ITdesk.info are the sole property of their respective authors. Microsoft, Windows and Windowsxx are registered trademarks of Microsoft Corporation. Other registered trademarks used on the ITdesk Home website are the sole property of their respective owners. If you have questions about using or redistributing any of the programs, please refer to the program license agreement (if any) or contact us via e-mail address info@itdesk.info.

These websites contain links to other websites or resources. ITdesk.info team is not responsible for the text and/or advertising content or products that these sites/resources provide, as it is not responsible for any content that is available through them, nor the possibility of the inaccuracy of the content. Use the links at your own risk. Furthermore, the ITdesk.info team does not guarantee:

- that the content on this website is free from error or suitable for any purpose,
- that these websites or web services will function without errors or interruptions,
- that they will be appropriate for your needs,
- that implementing such content will not violate patents, copyrights, trademark or other rights of any third party.

If you disagree with the general terms of use or if you are not satisfied with the sites we provide, stop using this website and web services. The ITdesk.info team is not responsible to you or any third party for any resulting damages, whether direct, indirect, incidental or consequential, associated with or resulting from your use, misuse of this website or web services. Although your claim may be based on warranty, contract violation or any other legal footing, regardless whether we are informed about the possibility of such damages, shall be released from all liability. Accepting the limitations of our responsibilities is a necessary prerequisite of using these documents, webpages and web services.

Please note that all stated software in this or other documents published at ITdesk.info is stated only for educational or exemplary purposes and that we in any case or manner do not prefer this software over any other similar software not mentioned in the materials. Any statement that would suggest that we prefer some software over other, mentioned or not mentioned in the materials, will be considered as a false statement. Only open source software that allows users to become digitally literate without barriers, use the computer and participate in the modern information society has our direct and unconditional support.
ITdesk.info – project of computer e-education with open access

Publisher:
Open Society for Idea Exchange (ODRAZI), Zagreb

ISBN: 978-953-7908-16-4