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Foreword 

 

Today's society is characterized by rapid growth and development of information 

technology (IT), which resulted in a great dependence of society, in a broad sense, 

of the knowledge and competence in the IT field. And although that dependence 

is growing from day to day,  human rights to education and information is not 

extended to the IT area. There were problems that affect society as a whole, 

creating gaps and distancing people from the main reason and motivation for 

advancement, from opportunity. Being a computer illiterate, today it means to be 

a person unable to participate in the modern society, to be a person without 

opportunity. Despite the recognition of the European Commission, UNESCO, 

OECD and other relevant institutions on the necessity and benefits of literacy, 

there are still groups of people with hindered access to basic computer education 

(eg. persons with disabilities, people with learning difficulties, workers / and 

migrants, the unemployed, people living in remote places where education is not 

accessible). 

This manual, together with other materials published on ITdesk.info, is our 

contribution to the realization and promotion of human rights to education and 

information in the field of IT. We hope that this education will help you in 

mastering basic computer skills and we wish you to learn as much as you can and 

thus becoming an active member of the modern IT society. 

Sincerely yours, 

ITdesk.info team  
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1. BASIC CONCEPTS 

1.1 DEVELOPMENT AND USE OF DATABASES 

 

 

Knowing the different types of database models: hierarchical, relational, object-oriented 

Hierarchical databases are found on hierarchical data structures, respectively on the 

structures in the form of a tree. The superior segment can have none, one or more specific 

segments, while a subordinate may have only one superior.  

Relational databases consist of a set of tables or relations. Data represent the entities of 

which each describes its properties. The entities are the ones that show up tables. They are 

mutually associated relations.  

Object-oriented databases are inspired by object-oriented programming languages. The 

base is permanently stored with a set of objects consisting of its internal data and methods 

for handling such data. Each object belongs to a class. Between classes are established 

relations with inheritance and aggregation. 

 

Knowing the stages of the life cycle of a database: logical design, database creation, data 

entry, data maintenance, finding data 

Logical design -> entities, attributes and domains of those methods are identified. The nouns 

that appear usually guide the entities and attributes, and adjectives and numeric data define 

the domains. The result of this step are the relations shown in the appropriate tables. This is 

followed by establishing interconnection and their presentation model Entities-Relationships 

(ER model). 

Database creation -> Based on the creation of an ER model and with the help of available 

tools for working with a database (DBMS - database management system - Oracle, MySQL, 

Microsoft SQL Server...) physically is created the database on your hard drive (usually on the 

server). At this stage is also programmed the application using the created database. 

Data entry -> filling table data, either manually or by importing data from other databases. 

Maintenance data -> comes down to repair errors that were not detected in the testing 

phase, the implementation of changes due to new user requirements, set parameters to 

improve performance. Maintenance requires constant monitoring of the base. 

Finding data -> direct queries to the database or through custom software. 
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Knowing the term SQL (structured query language) and understanding its main use to 

create, search, update and delete data from relational databases 

SQL is a query language based on relational algebra. It describes what we want to get as a 

result, but not how this result is coming. It combines the functions of language for data 

definition (DDL- Data Definition Language) and language for data management (DML- Data 

Manipulation Language). Its mission is to provide a definition, data management and 

implementation of control over data in a relational database. 

DDL commands are examples of commands for creating tables (CREATE), droping tables 

(DROP), renaming (RENAME) and similar. 

DML commands are examples of commands for selecting data (SELECT), inserting data 

(INSERT), updating data (UPDATE), deleting data (DELETE). 
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2. TABLES AND RELATIONS  

2.1 FIELDS/COLUMNS 
 

 

Create, modify, delete search in the field/column 

This option is only available to perform on forms (not on tables), by using a combo box or list 

box.  

Combo box and list box can be filled with data from the table, search or some predefined 

values. 

Adding control patterns is presented in the chapter 4. Forms. 

 

Create, modify, delete a mask to enter data in the field/column 

Input masks allow data validation, that is, they perform a preliminary check of the data in 

terms of the data entered format. Such example of mask for data entry can be set to show 

the date in the format DD-MM-YYYY (day, month, year).  

When creating a table, the input mask is defined to be of a certain column by clicking on the 

three dots near Format example. 

 

After that a dialog box opens, where you can select the desired format. 
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It is possible to define input masks in patterns. Once you have added on the form the input 

mask (Pattern field) with a right-click select Control in the General tab under Edit mask and 

define which characters are allowed in any position, while under Character mask you can 

define the layout. 

The figure below shows how could potentially look the mask for data entry in the format DD-

MM-YYYY. 

If under the Strict format you put Yes while typing in the input mask, it will automatically 

reject all entries that do not meet the defined sample (in the case of the figure below, if you 

try to enter a letter the effect will be as if you did not enter anything). 
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The characters that can be found in the Edit mask field are: 

L – serves as a label for a text constant. This position can not be changed (in the picture 

above this would be the hyphens -). 

a – serves as an indication that the place can be entered with lowercase and uppercase 

letters (a-z or A-Z). If you enter a lowercase letter it won't be turned into an uppercase one. 

A – serves as a marker that can be entered only with uppercase letters (A-Z). If you enter a 

lowercase letter it will be converted into an uppercase one. 

c – serves as a marker that can enter letters and numbers (a-z, A-Z, 0-9). Uppercase letter 

will not be turned into a lowercase one. 

C – serves as a marker that can be entered in uppercase leters (A-Z) or numbers (0-9). If you 

enter a lowercase letter it will be automatically turned into an uppercase one. 

N – can enter only numbers. 

x – serves as a marker that can enter any character.  

X – serves as a marker that can enter any character. If a lowercase letter is entered it will 

automatically turn it in an uppercase one. 

Change the input mask so that you mark it and with right-click select Control and make the 

desired changes. Delete it by marking it with pressing DELETE. 

 

Set the required input data values for field/column: it is necessary, it is not necessary 

If a table is created using SQL-a then the mandatory data entry is defined by the limitation 

NOT NULL. For example: 

CREATE TABLE "Person" ( 

"OIB" varchar(15) NOT NULL, 

"Name" varchar(20) NOT NULL, 

"Last name" varchar(20) NOT NULL, 

"Address" varchar(30) ) 

This command defined that the words from the table must not have blank spaces for OIB, 

Name and Last name. 
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If you create a table via the option “Create table in Design View“,  whether a field is required 

or not, is defined by selecting “Yes“ or “No“ under Entry required. 

 

 

2.2 RELATIONS AND JOININGS 

 

Create, modify, delete links between tables: one-to-one, one-to-many 

Relationships are defined by the relations between entities and tables.  

To be able to connect the table you must have a common element, respectively a column 

that contains the same attribute. 

In the relation one-to-one each row in the table A can be associated with only one row in the 

table B and inversely. 

If, for example, students are assigned PINs application for exam then one student can have 

only one PIN and one PIN can only belong to one student. 

This relation is established so that both tables have the same primary key, one of which 

becomes a foreign key. 

In the relation one-to-many, the row from one table can be associated with multiple rows 

from another table. For example, we have a table with the students and a table with 

enrollment lists. One student may have more enrollment lists, but an enrollment list can 

belong to only one student. 

This relation is established so that the table with the enrollment lists add a foreign key to the 

primary key in the table with the students, respectively tables with enrollment lists expand 

one column that contains the primary keys from the student table. 

To create a relationship go to Tools -> Relationships and in the dialog box that appears 

select Insert -> Add tables and add the table to which you want to define the relations. 
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You can create then relations by clicking Insert -> New Relation. 

In the dialog box that opens select the joining parameters, respectively the tables and the 

columns. For the relation between students and PINs it would look like in the picture below. 

 

After you click OK between selected tables/columns it will appear the relation line. It will be 

indicated the type of the relation. On the figure can be seen the number 1 at both ends of 

the line which indicates that the relation is one-to-one. 
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For entering the relation one-to-many there are the same steps with the difference that at 

the end of the line it will be 1 at one end and n at the other end. 

If you want to delete/modify a relation you can click on the relation line and select Delete 

respectively Edit. 

 

 

Create, modify relations between tables: many-to-many using the joining tables 

The relation many-to-many means that a row from one table can be related to multiple rows 

from another table and inversely. To demonstrate this relation creates additional tables use 

the joining table that serves as a link between two tables. It contains the primary keys of 

both tables as foreign keys, which typically represents its primary key (complex). 

If, for example, we have a table with enrollment lists and a table with objects, one 

enrollment list may contain several items and also one object can be placed on multiple 

enrollment lists. In this case, we could add a table Enroll which would contain SubjectID, 

EnrollmentListID and possible additional attributes such as evaluation, date, etc. 

The steps for creating relations are the same like for the relation one-to-one and one-to-

many, so select first Tools-> Relationships then Insert-> Add tables and at the end Insert -> 

New Relation. 

In this case, it is first necessary to connect the table Subject with the table Enroll and then 

the table Enroll with the table EnrollmentList. 

 

The relations can be changed by selecting the relation line, righ-click it and select Edit. 
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Apply referential integrity between tables, automatic updates of related fields, automatic 

deletion of related records 

When you create a relation, in the dialog box in which you define the tables and columns are 

displayed additional options that are applied when updating or deleting.  

 

The meaning of the option is: 

No action -> if there is a change in the line where is referenced the foreign key, the system 

for database management will not take any action. This option preserves referential integrity 

because they do not allow any changes that could lead to inconsistent state of the database. 

This means that if we want, for example, to delete a subject contained in the table Enroll this 

deletion will be prevented with an error message.  

 

In this way it can happen to find in the table Enroll subjects that no longer exist. 

In fact, when we have a table linked by a foreign key it is necessary to ensure that we do not 

have a foreign key that shows to a row that might have been deleted, because it would be in 

this way undermined the accuracy of data we have in the database. 

Update cascade/Delete cascade: this setting tells the system for database management that 

if there is a change in the primary key which shows the foreign key, the change will 

automatically reflect on the foreign key also in another table, respectively in the case of 

deletion of a certain primary key, it will be deleted a row in the second table that contains 

the foreign key of the same value as the primary one. 

If, for example, in the table Subject we change SubjectID for Mathematics to a different 

value, and if in the table Enroll is Mathematics, the value in it will automatically change. 
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Situation in the tables before: 

 

 

 

Situation in the tables after you changed Mathematics SubjectID on number 4: 

 

 

 

 

Also, if the line containing Mathematics in the table Subject is deleted, it will disappear the 

row (words) from the table EnrollmentList containing(e) Mathematics. 

Set null -> if there is a change in the primary key which references a foreign key, the value 

from the table containing the foreign key will be set to null, respectively to nothing, the 

same will happen if there is a deletion of a certain primary key which references a foreign 

key. 

If, for example, we have in the table Enroll under SubjectID the identifier of an object that 

was deleted, the situation would look after deletion like: 

 

Set default -> when defining attribute of the table or column, there is an option which can 

determine that some attribute has a default value. This means that if at the line entry in the 
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table for that column does not define any value for that row, the column will have the 

default value. For example, in the table Student we can have the attribute City whose 

default value will be Zagreb, and so will all the students who are otherwise stated as a value 

for City have Zagreb.  

The setting Set default acts as a Set null. It does not set a value on anything but the default 

value. If the default value is not defined when creating the table, then the setting behaves as 

No action. 

Scheme for the following examples: 

 

 

Change, reverse the internal, external joining 

Inner joining (INNER JOIN or just JOIN) is used to retrieve rows from the two tables that have 

the matching columns by which is done the joining. The inner joining can be seen at the 

intersection because returns only elements that are common to both tables. 

SQL syntax would be: 

SELECT name_column(s) 

FROM table1 

(INNER) JOIN table2 

ON table1.name_ column =table2.name_ column 
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If, for example, we want to retrieve the names and last names of only those students who 

took the exam, a command in SQL would look like: 

SELECT "StudentID", "Name", "Last name" 

FROM "Student" 

JOIN "Exam" 

ON "Student"."StudentID" = "Exam"."StudentID". 

When you create a query in Queries -> Create Query in Design View it will first open a dialog 

box in which you select the table from which it retrieves data. If among them is not defined 

the relation, add it by going to Insert -> New Relation. When you define the relation by 

clicking the line that represents the relation, select Edit then it will open a dialog box where 

you can define the type of joining. 

 

Once you have define the type of joining and which are the activated fields (ON part SQL query) on 
the bottom of the dialog box for queries define which fields you want to retrieve. For the purposes of 
this example we retrieve so the StudentID's name and  last name.  
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You can start the query by going to Edit -> Run Query. In this case, it will appear only 

students who are in the table Exam. 

 

Outer joining (OUTER JOIN) has 3 variations: 

- RIGHT OUTER JOIN 

SQL syntax: 

SELECT name_column(s) 

FROM table1 

RIGHT OUTER JOIN table2 

ON table1.name_column=table2.name_column 

This joining will return all rows from table2, and from table1 will return only those rows for 

which was found matching in the table2. Where there is no matching field the values will be 

NULL. 

- LEFT OUTER JOIN 

It acts the same as the RIGHT OUTER JOIN provided that returns all rows from table1 with 

the appropriate words from table2. If the table2 does not coincide with the data from table1 

the field's value will be NULL. 

- FULL OUTER JOIN (is not supported in all versions of the Base) 

It will return all rows in table1 and table2, with which will link the one with a matching. 

Where there is no matching, field's value will be NULL. 

Change the type of joining by clicking on the relation between tables and with right-click 

select Edit, then under Type select another type of joining. 
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Create, modify IS NULL joining (SUBSTRACT JOIN) 

This type of joining is the reversed version of OUTER JOIN. It returns the difference between 

tables. 

If we want to reach, for example, all students who are not on the table Exam, query would 

read: 

SELECT * 

FROM "Student" 

LEFT OUTER JOIN "Exam" 

ON "Student"."StudentID" = "Exam"."StudentID" 

WHERE "Exam"."StudentID" IS NULL 

 

Apply joining of the tables with themselves 

When you join the table with only itself, it mostly questions when the table has a foreign key 

that references its primary key. Joining the table with only itself means that each row of the 

table combines only with itself and with other rows in the table. You can look on this like on 

the joining of two copies of the same table. Since the same table appears twice, it is 

necessary to use aliases. 

A school example of this case is monitoring the situation of employees and their managers. 

So, there are the managers and employees as they are all in the same table,  with the unique 

number of employees (EmployeeID) primary key and the number of managers (ManagerID) 

foreign key that references the primary key in the same table. 

Example query to retrieve the employees and their managers:  

SELECT "emp".*, "man".* 

FROM "Employee" emp 

INNER JOIN "Employee" man 

ON "zap"."ManagerID" = "man"."EmployeeID" 

For a table as shown below to get the result as shown below: 
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3. QUERIES 

3.1 TYPES OF QUERIES 

Introductory note 

We can only create and run queries without pushing them to store for future use, by going 

to Tools- > SQL and enter the command to be executed. 

If we want to save the query, then it could be done either through Insert -> Query (SQL 

View) or Insert -> Query (Design View). These two options are essentially doing the same 

thing, just as SQL View directly entering SQL commands while in Design View queries are 

created by checking the appropriate boxes. 

SQL View: 

 

Design View: 
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The following example will be processed using the scheme given in the figure: 

 
 

Create, run a query to update the data in the table 

The table Student presents data as shown below.  

 

For updating data is used the syntax: 

UPDATE name_table 

SET name_column=value 

WHERE some_condition 

If, for example, it's necessary for a student having StudentID=1 to set the value of the 

column City to Split, then it will look: 

UPDATE “Student“ 

SET “City“='Split' 

WHERE “StudentID“=1. 
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In Base go to Tools -> SQL. This will open a dialog box in which, in the “Command to 

execute“, you enter the command. After that, click on Execute. In the text box Status 

message is printed on, whether the order has been successfully or there is some error.  

 

 

Create, run a query to add records to a table 

Adding records is made by using INSERT command: 

INSERT INTO name_table (column1, column2, column3....) 

VALUES (value1, value2, value3....). 

There are several options: 

1. If we bring a record in which we define all values of the column, then is not necessary 

to include names of the columns in the command, respectively the command can be 

written shortly with INSERT INTO name_table VALUES (values of the column). 

2. If we enter only some values, it is necessary to specify the names of the columns in 

which we bring value, respectively INSERT INTO name_table (column1, column3, 

column5) VALUES(value1, value2, value3) 

3. If we enter the value of a different order than how the columns are arranged in the 

table, it is necessary to specify the column names in the order we enter the 

information, repectively INSERT INTO name_tablice (column3, column2, column1) 

VALUES (value1, value2, value3). 
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Running a query is made the same as for updating via Tools -> SQL. 

To enter a new student in the table Students the command would look like: 

INSERT INTO "Student" 

VALUES ('5', 'Franić', 'Frane', '543543564', '08.04.1995', 'Zagreb') 

 

Create, run a query to delete records in the table 

Deleting records is done with the DELETE command: 

DELETE FROM name_table 

WHERE some_condition 

If you omit WHERE part, it erases the entire content of the table. 

To delete, for example, a student who has ID=2 you must run the command: 

DELETE FROM "Student" 

WHERE "StudentID"=2 

 

Create, run a query to save selected data as a new table 

The command to accomplish this is SELECT INTO command with syntax: 

SELECT columns INTO new_table 

FROM old_table 

WHERE condition 

After you start this command, the Base automatically creates a new table and in it puts the 

data depending on the above conditions. 

If, for example, we want to create a new table in which to include only students whose 

StudentID is greater than 2, the command would be: 

SELECT * 

INTO "Student_copy" 

FROM "Student" 

WHERE "StudentID">2. 



ITdesk.info – project of computer e-education with free access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Noncommercial-No Derivative Works 3.0 Croatia License   22/47 

After you refresh the table (View -> Refresh tables) in the list of the tables appears the newly 

created table. 

 

 

Create, run a crosstab query 

Crosstab query (CROSS JOIN) returns a table where each row from the first table is 

connected to each row of the second table, and mathematically returns Cartesian product 

table. 

Crosstab query can be specified in two ways: 

1. Using CROSS JOIN keywords (this option is not available in the Base if you entered 

the query via Tools -> SQL, but is available in the defining of the joining as explained 

earlier in the manual). 

SELECT * 

FROM  table1 

CROSS JOIN table2 

2. By simply stating the names of the tables in the FROM query part 

SELECT * 

FROM table1, table2. 

 

Create, run a query to show duplicated records in the table 

In the Base there is no automatic way of creating such query (unlike Access), but there is a 

roundabout way. 

Let's say that in the table Student we want to check whether a student may be entered 

twice. We can use as criteria OIB students identity, if it's the same. 

You must first need to create a query that retrieves OIBs and, by grouping, checks whether 

some OIBs appear several times. 
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SELECT "OIB", Count(*) 

FROM "Student" 

GROUP BY "OIB". 

If this query in the column Count returns for a line number greater than 1 it means that we 

have a duplicate. 

 

Now we can retrieve the rows with duplicates in the way that, in the SELECT command, in 

the WHERE part, we state as criteria that OIB is equal to the OIB in which it appears in this 

case, 2 times. 

SELECT * FROM "Student" 

WHERE "OIB"= 654653644 

 

Create, run a query to show unmatched records in related tables 

In the Base there is no automatic way of creating such query (unlike Access), but is available 

the previously processed NULL joining (SUBSTRACT JOIN). 

 

3.2 REFINING QUERY 

 

Create, modify, run a parameter query with one, two variables 

To create a query go to Insert -> Query (SQL View).  

In the dialog box, enter the command. Parameter queries are working in a way that the 

criteria should not be entered directly into the query but when you run the query it opens 

the input field where the user seeks to define the criteria. Let's say, for example, we want to 

retrieve information about a student. Rather than write a query that will always retrieve 

data for a particular student, write a query in a way that the user himself, when starting the 

query, should define the data for any student he wants in a way to enter his name. 

In this case the command would look like: SELECT * FROM "Student" WHERE "Name" = 

:Name. 
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:Name is a parameter query, that tells the system maintenance base that on this place a 

specific value will come later. 

 

After you enter the query click on Save and give a name to the query. 

Query will appear on the list of queries. 

 

If you now double-click on the query, it will open with a dialog box asking you to define a 

value for the variable Name. 

 

After entering the name it will be displayed the result of the students searching in the 

entered name. 

 

The procedure for parameter queries with 2 variables is exactly the same except that you 

have, when creating queries, to define 2 variables for entry. For example: SELECT * FROM 
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"Student" WHERE "Name" = :Name AND “City“= :City. When you now run the query you 

need to enter two parameters for the search. 

 

Use wildcards in the query 

Base supports wildcars * (replaces any number of arbitrary characters) and ? (replaces 

exactly one arbitrary character). 

Wildcards are generally used with the operator LIKE. 

Let's say you want, from the table Student, to retrieve all the students whose last name ends 

in “ic“, the command would be: 

SELECT *  

FROM “Student“ 

WHERE “Last name“ LIKE '*ic'. 

 

Show highest, lowest range of values in a query 

For retrieving the range in the query the Base supports keyword LIMIT. Using these 

keywords you can limit the number of the rows retrieved. To retrieve rows from the 

top/bottom is used in conjunction with ORDER BY. 

Let's say you want to retrieve 2 subjects that have the least hours of lectures, the command 

would be: 

SELECT * FROM "Subject" 

ORDER BY "HoursLectures"  

LIMIT 2. 

ORDER BY automatically sorts the data from smallest to largest. If we want to retrieve 2 

objects with the most hours of lectures it is necessary to add the DESC in sorting the data to 

be sorted from highest to lowest. 

SELECT * FROM "Subject" 

ORDER BY "HoursLectures" DESC 

LIMIT 2. 
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Create and name a field that performs arithmetic operations 

Go to Insert -> Query (Design View) and select first the table. 

 

For the purposes of this exampe, it will be made a field that account the total number of 

hours of lectures and exercises for a particular subject. 

In the lower part of the window under Field choose the fields you want to display. In the first 

empty column enter then the definition of a field that performs arithmetic operations. Since 

we want to get the total number of hours in this case was entered HoursLectures +  

HoursExercises. The column is given an alias TotalHours. 

 

In order to verify the correctness go to Edit -> Run Query. In this case, the result will look like 
this: 

 

It appears an additional column containing a defined sum. 
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Group information in a query using functions: sum, count, average, max, min  

SUM -> returns the sum of a numeric column. 

In the table Subject we have defined for each subject a number of teaching hours and hours 

of practice. 

 

If we want to know the total number of the hours of lectures and excercises of the subject 

we can use SUM: 

SELECT "SubjectName", SUM("HoursLectures" + "HoursExercises") AS "TotalHours"  

FROM "Subject" 

GROUP BY "SubjectName" 

This command tells us that if we sum up the hours of lectures and exercises in the column 

named TotalHours they are grouped by subject name. 

The result of this command is the table: 

 

COUNT -> returns the number of rows that match the specified criteria. 

If we want to find out, for example, the number of the subjects that have a certain number 

of hours of lectures this will be defined with the command: 

SELECT "HoursLectures",  COUNT("HoursLectures") 

FROM "Subject" 

GROUP BY " HoursLectures" 

 

The result of this command is a table: 
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The base contains two subjects that have ten hours of lectures and one subject with eight 

hours of lectures. 

AVERAGE (AVG) -> returns the average value of a numeric column. 

Let's say you want to find out the average grade achieved in the exams by subject. 

The command would read: 

SELECT "SubjectID", AVG("Grade") AS "Average grade" 

FROM "Exam" 

GROUP BY "SubjectID" 

 

MIN -> returns the minimum value of certain columns. 

If, for example, we want to find the lowest grade on the exam the command would read: 

SELECT "SubjectID", MIN("Grade") AS "Average grade" 

FROM "Exam" 

GROUP BY "SubjectID" 

MAX -> returns the minimum value of certain columns. 

If we want to find the top grade on the exam the command would read: 

SELECT "SubjectID", MAX("Grade") AS "Average grade" 

FROM "Exam" 

GROUP BY "SubjectID" 
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4. FORMS 

4.1 CONTROLS 

 

Create, modify, delete bound controls: text box, combo box, list box, check box, radio 

button. 

Related controls are associated directly with the fields in  the table or query on which the 
form refers. 

Text box (textBox) -> it can be seen the value of a field in a table or the result of some 
research. 

Combo box (comboBox) -> allows you to select values from a list that opens by clicking on 
the arrow. 

List box (listBox) -> the list is the presented frame that holds multiple lines. 

Check box (checkBox) -> is presented with shells that can be marked. 

Radio button (radio button) -> allows you to select an option within the framework of which 
only one can be labeled at a particular moment. 

Controls are created by clicking on Forms -> Create Form in Design View. After that, it will 
open a window for editing the form (as in Writer). 

To edit form, click on Design mode On/Off. 

 

From the controls toolbars select the desired control, click on it and drag it to the form. 

To edit control, mark it by clicking right to select Control. This will open a dialog box in which 
it is then possible, depending on the type of control, to select the desired option. 

Before that, it's necessary to link the form to a table/query. Mark the control and by right-
clicking select Form. In the Data tab, define the data source. 
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Apply, remove bound control properties such as: list limitations, different values 

The base does not support these features. 

 

Create, modify, delete unbound controls containing arithmetic, logical expressions 

In the base is not possible to create or modify controls that contain arithmetic and logical 

expressions directly but through queries. So, you need to create a query that performs 

arithmetic/logical operations (as previously discussed) and so this field is then connected to 

the control. 

 

Change the sequential order of controls on a form 

Right-click on the form and select Edit. 

After that, click on Activation Order and when the dialog box with Move Up/Move Down 

opens, move the desired item. 

 

 

Create, delete linked below form 

Select Forms and click Use Wizard to Create Form.  

It will then run “wizard“ to guide you through the process of creating forms. 

First, select a table/query/view which is to be linked with the form and define the fields you 

wish to display. 
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In the next step, the subform is created. The subform shows data from tables or queries that 

are associated with the subject selected in the first step. It can be inserted the subform that 

already has an existing relationship with the subject from the first step or you can choose an 

option to manually select the field connections. 

 

The third step is defining the fields that you wish to display in the subform. 

Further steps are related mainly to the editing of the forms' looks. 
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In the example from the figures, as a result of inserting the subform Subject to the form 

Teacher is given the form in which, for every teacher in the subform, is displayed 

information about the subject that is taught. 

 

The subform can be easily deleted so that the Form opens for editing (right-click on the 

name of the form and select Edit) and then mark the items of the subform in the form and 

press DELETE. 
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5. REPORTS 

To work with the reports you need to install the extension Report Builder, then is necessary 

to add an extension to the base via Tools -> Extension Manager then click Add. 

The extension can be downloaded at: http://extensions.openoffice.org/en/project/oracle-

report-builder. 

 

 

 

5.1 CONTROLS  

 

Establish arithmetic calculation controls in a report: percentage, currency, determine the 

number of decimal places 

After you select a control on a report, on the right side appears the menu where you can 

define various parameters for control.  

 

http://extensions.openoffice.org/en/project/oracle-report-builder
http://extensions.openoffice.org/en/project/oracle-report-builder
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Click on the three dots next to Formatting option and in the dialog box that appears, set the 

desired shaping. 

 

 

Apply the subtotal for the group, for all 

This option is not automatically implemented, but it can be realized through the queries 

which can then be connected to a control on the form. 

Let's say we have a table with employees and sales volumes of the products: 



ITdesk.info – project of computer e-education with free access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Noncommercial-No Derivative Works 3.0 Croatia License   35/47 

 

 

If we want to show the subtotal of sales volumes, in the query we have to apply compound 

table with itself and with the WHERE and GROUP clause: 

SELECT a1.Name, a1.Sales, SUM(a2.Sales) Subtotal  

FROM Sales a1, Sales a2  

WHERE a1. Sales <= a2. Sales or (a1. Sales a=a2. Sales and a1.Name = a2.Name)  

GROUP BY a1.Name, a1. Sales 

ORDER BY a1. Sales DESC, a1.Name DESC; 

The result of running this query is: 

 

 

Merge fields in the report 

This option is not directly supported. It is possible to make a query or a view in which to 

connect fields and then make a report based on the query/view. 

 

5.2 DISPLAY  

 

Insert, delete fields in a group, page, report headers and footers 

It is necessary, primarily, to distinguish the header/footer pages, reports and groups. In the 

picture below, the header/footer page is painted orange, the reports green and the groups 

blue. 

 



ITdesk.info – project of computer e-education with free access 

ITdesk.info is licensed under a Creative Commons Attribution-  

Noncommercial-No Derivative Works 3.0 Croatia License   36/47 

 

 

 

To add a field mark to the desired section go to View -> Add Field and select from the dialog 

box that then opens. 

 

 

Sort, group records in a report by field or fields 

Click on Sorting and Grouping button and then in the dialog box that opens, select the 

field/s for grouping/sorting. In addition, it is possible to define the criteria of sorting 

(ascending/descending), that you would like to display the header/footer for the group, 

whether it will be grouped by any value or at any interval, and if the option is selected for 

each interval, is possible to define the size of the interval.  
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Set a page layout to the group report 

Once you have defined the grouping, select the header or the footer of the group and in 

properties (on the right side of the screen) select the desired layout. 

 

 

Create, delete linked below reports 

This option is not available in the base. 
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6. IMPROVE PRODUCTIVITY 

6.1 LINKAGE AND IMPORT 

 

Link external data to a database: spreadsheets, text (. txt,. csv), existing database 

Linking, unlike importing data, allows users to work over the same data. Any changes that 

occur over the original tables will automatically be mapped to the associated table. Any 

changes to the data must be made on the original tables, not on the connected, data can 

only be seen in the associated table. It is possible to link the information in the existing 

database but for this purpose it is necessary to create a new database.  

If you link the workbook, it will be created as many tables as there are worksheets and each 

table will have a name as a worksheet. 

In order to link data, go to File -> New -> Database and select Connect to an existing 

database.  

 

 

Choose then from the drop-down menu where to link data: 
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For the presentation, it will be shown the data linkage with the workbook. After clicking on 

Spreadsheet, it opens a dialog box in which you are requested to specify the path to the 

workbook.  

 

When you are finished with the process of connecting, you will need to provide the name of 

the new database and save it. After that, the new database will open and in it will be as 

many tables as there were worksheets in a workbook (in this case, a single worksheet so that 

it will open only one table). 

Note: when you create a baseline connecting external data, you can't create additional 

tables. 
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Import spreadsheets, text, (. txt,. csv), XML, existing database to database 

Import data from other applications (.txt, .csv, XML) is carried out mainly through the 

mediation of Calc, respectively the data is imported into Calc, and then easily transferred to 

the base. 

From the existing database is possible to introduce any object (tables, queries, forms, 

reports, macro) in a very simple manner by simply dragging from one database to another or 

by copying. 

Import data from existing database: 

- Open both databases 

- Choose the object you want to copy and select Copy by right-clicking 

- In the destination table, by right-clicking, select Paste 

- If selected for copying tables, it will open a dialog box through which you can define 
the name and the characteristics of the table and column 
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At the end, the table will appear in the list of the tables from the destination database. 

Import data from a workbook: 

- Open the workbook and database where you want to copy data 

- Select the cells you want to copy the worksheet (header must be present) 

- Using Copy/Paste to copy the data and define the characteristics of the table and 
column (like in the case of importing data from existing databases).  
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6.2 AUTOMATION 

 

Create a simple macro like: close an object and open another one, open and maximize an 

object, open and minimize an object, print and close an object 

The possibility to create macro commands via a graphical interface in the base is still limited. 

It is available the possibility to create macro commands using programming languages Basic, 

Phyton, JavaScript, but it goes beyond the scope of this guide. 

A simple macro command is now possible to create only for forms. 

Open the form for editing (right-click on the form and then Edit) then go to Tools -> Macros -

> Record Macro. 

At this point, it starts the recording and it will be recorded every action you make on the 

form. At the end, click on Stop recording. 

 

Upon completion of recording, it opens a dialog box in which you can define a name  for the 

macro command and save it. 

 

 

Asign/attach a macro command button on the toolbar, object, control 

To add a macro command to the toolbar go to Tools -> Customize then under Toolbars 

choose Toolbar. Then click on Add to open a dialog box in which you need to find the desired 

macro command and click on Add. 
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Macro command will then appear in the list of toolbar commands. 

 

Respectively, will be visible in the toolbar. 

 

If you want to assign a macro to a control from the example, add, for example, the first 

element on the form (in this example, we add a button). 
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Then, by right-clicking on the button, select Control.  

In the tab Events under event click (Mouse button pressed) on the button with three dots. 

 

This will open a dialog box in which you need to click on Macro and then choose the desired 

macro. 
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This manual is intended for learning in conjunction with materials published on the 
following links: 

 

Using quizzes published on the links below, test kowledge of advanced work with databases 

in Microsoft Access 2010 (prepared and drafted: Gorana Čelebić) 

Table design – Fields, columns: 

Apply and change data types such as text, memo, hyperlink, currency, 

date & time in the field (column); 

Understand consequences of changing data types; 

Create, modify, delete a LOOKUP in a field (column); 

Create, edit the rule of data verification (validation rule) for the field 

(column); 

Create, edit the input mask in the field (column); 

Apply, change the default values for the field (column); 

Set a field (column) that requires mandatory data entry 

Tables design – Relations/Connections: 

Create, modify relationships between tables of type one–to–one and 

one–to–many; 

Understand and change the relationship between the tables of the 

many–to–many type; 

Apply, modify inner join, outer join and self join; 

Apply referential integrity and automatic deletion of related records; 

Connect/merge data when creating queries 

start the quiz  

Query design (Queries) – Types of queries: 

Create and use a query to update the data in the table; 

Create and use a query to delete records from the table; 

Create and use a query to save selected data as a new table; 

Add records to a table using the query; 

Group information in the query using: SUM, COUNT, AVERAGE, MAX, 

MIN; 

Create, run a crosstab query; 

Use wildcard characters in a query; 

Use arithmetic and logical expressions in a query 

Query design (Queries) – Adjusting a query: 

Display duplicates; 

Create, run a query to show unmatched records in related tables; 

Show highest, lowest range of values in the query; 

Allow the entry of arbitrary parameters in the query via the data input 

box (parameter query); 

Adjusting a query by using the NULL and NOT 

start the quiz  

http://www.itdesk.info/en/module-5-using-databases/advanced-databases-table-design-fields-columns-quiz/
http://www.itdesk.info/en/module-5-using-databases/advanced-databases-query-design-quiz/
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Forms design (Forms) – Controls: 

Create, modify, delete bound and unbound controls; 

Create, modify, delete controls: combo box, list box, check box and 

option groups; 

Create controls with arithmetic or logical expressions on the form; 

Insert a data field that will appear in the header of the form, the footer 

of the first page or all pages 

Forms design (Forms) – Subforms: 

Create, delete a linked subform; 

Modify a subform to change displayed records 

Report design – Computing: 

Create controls for arithmetic or logical computation on the report; 

Create a control to calculate the percentage on the report; 

Use formulas and expressions on the report, e.g. SUM, COUNT, 

AVERAGE, MAX, MIN, CONCATENATE; 

Create the current totals on the report 

Report design – Presentation: 

Insert a data field that will appear in the header of the report, the footer 

of the first page or all pages; 

Force page breaks for groups of data on the report 

Macros – Recording and i assignment: 

Record a simple macro, e.g., closing a form; 

Run a macro; 

Assign/attach a macro to a form, a report, a control 

Import, export and linking data – Data management: 

Import files (text, spreadsheet, .csv, dBase, Paradox) into a database; 

Export data as a spreadsheet, text, dBase, Paradox; 

Link external data to the database 

start the quiz  

 

 

 

 

  

http://www.itdesk.info/en/module-5-using-databases/advanced-databases-forms-design-macros-import-data-quiz/
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TERMS OF SERVICES  

Web–page www.ITdesk.info is launched by the organization “Open Society for Idea 
Exchange - ODRAZI“ in order to actively promote human rights to free access to 
information and education. 

Feel free to copy and distribute this document, provided that you won't change 
anything in it!  

All free programs and services listed on the web–page ITdesk Home on the web adress ITdesk.info 
are the sole property of their respective authors. Microsoft, Windows, and Windowsxx are registered 
trademarks of Microsoft Corporation. Other trademarks used on ITdesk Home web-site are the sole 
property of their respective owners. If you have questions about using or redistributing any program, 
please contact the authors of the program. Any further questions please send to info@itdesk.info.  

___________________________________ 

This web–site contains links to other web–sites or sources. ITdesk.info team is NOT responsible for 
the textual and/or advertising content, or products that are on these web– sites /offered sources, as 
is NOT responsible for any content that is available through them; the possibility of the accuracy of 
the content. Use links at your own risk. Also, ITdesk.info does not guarantee: 

 that the content on the new web-site is free from error or suitable for any purpose, 

 that this web–site or web services will function without error or interruption, 

 that it would be appropriate for your needs, 

 that implementing such content will not violate patents, copyrights, trademarks or other 
rights of a third party. 

If you do not agree with the general terms of use or if you are not satisfied with the provided web–
pages, stop using these web–sites and web services. ITdesk.info team is not responsible for you or 
any third party for any resulting damages, whether direct, indirect, incidental or consequential, 
associated with resulting from your use or misuse of this web–site or web services. If your claim may 
be based on warranty, contract violation or any other legal footing, regardless whether we are 
informed about the possibility of such damages, we shall be released from all liability. Accepting the 
limitations of our responsibilities is a necessary prerequisite for the use of the new web–site and web 
services. 

All listed software in this or other documents published on ITdesk.info are stated only for educational 
or exemplary purposes or, for example, that we, in any way, do not prefer the named software in 
relation to other software. Any statement that we prefer some software over to the other, 
mentioned or not mentioned in materials, will be considered as false statement. Our direct and 
unconditional support has only open source software (open source) that allow users without barriers 
to become digitally literate, use computer and participate in the modern information society. 
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